Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1158

Deploying plugin fails with 401

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: artifactory
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      Trying to deploy the testrail plugin and I'm getting this error. Worked with Daniel Beck a few weeks ago to try to resolve but met no success. I've attempted everything I could in the wiki, even scrapping my dev environment and doing it all over again. I've also made sure my permissions are in the repository. This may be related to INFRA-1114. The relevant part of my build failure is below.

      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 01:18 min
      [INFO] Finished at: 2017-04-16T08:46:35-05:00
      [INFO] Final Memory: 67M/372M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.8.2:deploy (default-deploy) on project testrail: Failed to deploy artifacts: Could not transfer artifact org.jenkinsci.plugins:testrail:hpi:1.0.5 from/to maven.jenkins-ci.org (https://repo.jenkins-ci.org/releases/): Failed to transfer file: https://repo.jenkins-ci.org/releases/org/jenkinsci/plugins/testrail/1.0.5/testrail-1.0.5.hpi. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1]http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

      I can produce my effective pom if desired.

       

      Thank you and I appreciate any assistance.

        Attachments

          Activity

          Hide
          danielbeck Daniel Beck added a comment -

          Adam Chevalier Given the regularly happening uploads from other users, and the fact that this is 401 Unauthorized (rather than 403 Forbidden), it is not an infra issue. Your client does not send authentication. I suggest you ask on the jenkinsci-dev mailing list for help. The people looking into infra issues are very likely to be unable to help you.

          Show
          danielbeck Daniel Beck added a comment - Adam Chevalier Given the regularly happening uploads from other users, and the fact that this is 401 Unauthorized (rather than 403 Forbidden), it is not an infra issue. Your client does not send authentication. I suggest you ask on the jenkinsci-dev mailing list for help. The people looking into infra issues are very likely to be unable to help you.
          Hide
          xirsoi Adam Chevalier added a comment -

          Thank you for the prompt reply and the redirect to the correct place.

          Closing this ticket.

          Show
          xirsoi Adam Chevalier added a comment - Thank you for the prompt reply and the redirect to the correct place. Closing this ticket.
          Hide
          xirsoi Adam Chevalier added a comment -

          Entered erroneously

          Show
          xirsoi Adam Chevalier added a comment - Entered erroneously

            People

            • Assignee:
              danielbeck Daniel Beck
              Reporter:
              xirsoi Adam Chevalier
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: