Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1167

Debian package for Jenkins 2.54 is missing Java 8 dependency

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      In issues JENKINS-43495 and JENKINS-43629 users are encountering that their Jenkins breaks if they install Jenkins 2.54 via apt (pkg.jenkins.io). This is caused by a missing dependency to Java 8 on the package.

      The issue was resolved for the Jenkins 2.55 package by adding the Java 8 dependency. But because the 2.54 package is still present on pkg.jenkins.io without a dependency to Java 8 systems that do not have the option to install Java 8 will automatically install Jenkins up to 2.54, breaking their Jenkins installation.
      A good example of this is Ubuntu 14.04 which has no official support for Java 8. Installing Jenkins on these systems will result in 2.54 being installed.

      To resolve the issue please remove the Jenkins 2.54 package from pkg.jenkins.io and/or update the 2.54 package to add the Java 8 requirement.

        Attachments

          Issue Links

            Activity

            Hide
            rtyler R. Tyler Croy added a comment -

            I brought this up on the jenkins-infra mailing list and we decided against removing 2.54

            The next LTS baseline releases will properly declare their Java 8 dependency. In the meantime I recommend running the current LTS, which supports Java 7 still, in all production environments.

            Show
            rtyler R. Tyler Croy added a comment - I brought this up on the jenkins-infra mailing list and we decided against removing 2.54 The next LTS baseline releases will properly declare their Java 8 dependency. In the meantime I recommend running the current LTS, which supports Java 7 still, in all production environments.
            Hide
            stephenking Steffen Gebert added a comment -

            Unfortunately, this is still the same for 2.60.1.

            Show
            stephenking Steffen Gebert added a comment - Unfortunately, this is still the same for 2.60.1.

              People

              • Assignee:
                rtyler R. Tyler Croy
                Reporter:
                jbogers Jeroen Bogers
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: