Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1589

Runaway Docker runs in runATH() cause workspace collisions

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: etc
    • Labels:
      None
    • Similar Issues:

      Description

      Noticed it while working on JENKINS-50933.

      Due to whatever reason, I see collisions in the workspace (https://ci.jenkins.io/job/Core/job/remoting/job/PR-265/). These collisions are related to ATH files, e.g.

      Caused by: java.io.FileNotFoundException: ../../../ath/athSources/unsafe.key (No such file or directory)
          at java.io.FileInputStream.open0 (Native Method)
          at java.io.FileInputStream.open (FileInputStream.java:195)
          at java.io.FileInputStream.<init> (FileInputStream.java:138)
          at org.apache.commons.io.FileUtils.doCopyFile (FileUtils.java:1141)
          at org.apache.commons.io.FileUtils.doCopyDirectory (FileUtils.java:1446)
          at org.apache.commons.io.FileUtils.doCopyDirectory (FileUtils.java:1444)
          at org.apache.commons.io.FileUtils.doCopyDirectory (FileUtils.java:1444)
          at org.apache.commons.io.FileUtils.copyDirectory (FileUtils.java:1388)
          at org.apache.commons.io.FileUtils.copyDirectory (FileUtils.java:1268)
          at org.apache.commons.io.FileUtils.copyDirectory (FileUtils.java:1237)
          at io.jenkins.tools.warpackager.lib.impl.Builder.buildIfNeeded (Builder.java:190)
          at io.jenkins.tools.warpackager.lib.impl.Builder.build (Builder.java:69)
      

      So something tampers the workspace while the "copyDirectory" command is running

      The run happens when there is no other running builds in WebUI. My assumption is that there is a runaway runATH() Docker container from a previous build, but I cannot confirm that with my permissions.

      CC Raul Arabaolaza Olivier Vernin

        Attachments

          Issue Links

            Activity

            rarabaolaza Raul Arabaolaza added a comment -

            Olivier Vernin I can start with this (as the runATH code was developed by me) and ping you if some infra need arises.

            olblak Olivier Vernin added a comment -

            Show
            olblak Olivier Vernin added a comment -
            rarabaolaza Raul Arabaolaza added a comment -

            Why is the war packager trying to load a file from ath folder?

            rarabaolaza Raul Arabaolaza added a comment -

            So after a quick sync with Oleg Nenashev it seems the problem being a broken symbolic link in the ath sources so it does not make sense to have this fixed here but on the ATH itself, so I have created https://issues.jenkins-ci.org/browse/JENKINS-50952 and closing this for the moment

            rarabaolaza Raul Arabaolaza added a comment -

            As said the problem is on the ATH containing a broken link, so closing for the moment and created JENKINS-50952


              People

              • Assignee:
                rarabaolaza Raul Arabaolaza
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: