Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1769

Provide readonly access to the evergreen DB for debugging to Evergreen developers

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: evergreen
    • Labels:
      None
    • Similar Issues:
    • Sprint:
      Evergreen - Milestone 1, Evergreen - Milestone 2

      Description

      As we're opening Evergreen alpha and having some versions running in the wild, it would be handy that we get access to the DB (readonly is enough) to understand/debug a few things. 

      Person to provide access to:

       

        Attachments

          Activity

          batmat Baptiste Mathus created issue -
          batmat Baptiste Mathus made changes -
          Field Original Value New Value
          Assignee Baptiste Mathus [ batmat ]
          batmat Baptiste Mathus made changes -
          Assignee Baptiste Mathus [ batmat ] R. Tyler Croy [ rtyler ]
          rtyler R. Tyler Croy made changes -
          Rank Ranked higher
          rtyler R. Tyler Croy made changes -
          Rank Ranked lower
          olblak Olivier Vernin made changes -
          Rank Ranked higher
          rtyler R. Tyler Croy made changes -
          Sprint Evergreen - Milestone 1 [ 511 ] Evergreen - Milestone 1, Evergreen - Milestone 2 [ 511, 516 ]
          rtyler R. Tyler Croy added a comment -

          Olivier Vernin, do you think this is something you could be able to figure out? I don't have a lot of bright ideas for how we can share access to Azure DBs

          rtyler R. Tyler Croy made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          olblak Olivier Vernin made changes -
          Assignee R. Tyler Croy [ rtyler ] Olivier Vernin [ olblak ]
          olblak Olivier Vernin made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          olblak Olivier Vernin added a comment -

          Currently the database block all connections excepted a list of whitelisted IP and because everybody doesn't have a static ip available, we need to deploy a ssh gateway with postgesql-client configured with read only access in the evergreen namespace to allow people to jump there and run command.

          We could build a docker image that contains ssh authorized keys and an openssh server

          batmat Baptiste Mathus added a comment -

          That would be fine by me. If needed, my pubkey is also available at https://batmat.net/pubkey.txt

          olblak Olivier Vernin added a comment -

          I created a PR which needs some reviews.

          Baptiste Mathus Mandie Smith I also created a docker image that contains sshd and postgresql-client configured on them, can I ask you to add your public ssh key?
          It should be straightforward.

          batmat Baptiste Mathus added a comment -

          > can I ask you to add your public ssh key?

          Olivier Vernin sorry to be a slowpoke, but where? I already provided a link to mine above, not sure where you mean. Thanks!

          olblak Olivier Vernin added a comment -

          > I already provided a link
          You shared a link to your public GPG key not public ssh key

          > where?
          Indeed I forgot to put the link https://github.com/jenkins-infra/sshd
          Just skip step 1

          batmat Baptiste Mathus added a comment -

          > You shared a link to your public GPG key not public ssh key

          Woops, right. :facepalm:

          Thanks for the link

          batmat Baptiste Mathus added a comment -
          asmith_cb Mandie Smith added a comment -
          olblak Olivier Vernin added a comment -

          Read only access is configured from 137.116.80.151. It should be easy to understand how to use that endpoint. Btw ip will probably change in a near futur so I suggest to create a dns record to keep track of it
          https://github.com/jenkins-infra/azure/pull/74

          olblak Olivier Vernin made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          batmat Baptiste Mathus added a comment -

          wooot, I can confirm this works. Just used to retrieve older UL content for debugging JENKINS-54358. Merci beaucoup Olivier Vernin!

          olblak Olivier Vernin made changes -
          Status Resolved [ 5 ] Closed [ 6 ]

            People

            • Assignee:
              olblak Olivier Vernin
              Reporter:
              batmat Baptiste Mathus
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: