Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1804

Please update jenkins/pct to use at least maven 3.5.4

    Details

    • Type: Task
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: etc
    • Labels:
      None
    • Similar Issues:

      Description

      According to Raul Arabaolaza there are possible problems running the PCT with a version of maven prior to 3.5.4.  The current jenkins/pct image is built on 3.5.2.

       

        Attachments

          Activity

          Hide
          rarabaolaza Raul Arabaolaza added a comment -

          Basically, plugins using incrementals. They need 3.5.4 with lower versions the PCT is not going to be able to compìle them and as no tests are run is difficult to realize unless you look at the HTML report

          Show
          rarabaolaza Raul Arabaolaza added a comment - Basically, plugins using incrementals. They need 3.5.4 with lower versions the PCT is not going to be able to compìle them and as no tests are run is difficult to realize unless you look at the HTML report
          Show
          kearls Kevin EARLS added a comment - Fixed with https://github.com/jenkinsci/plugin-compat-tester/pull/81

            People

            • Assignee:
              kearls Kevin EARLS
              Reporter:
              kearls Kevin EARLS
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: