Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1924

Jenkins Hangouts channel does not work reliably

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Won't Do
    • Component/s: etc
    • Labels:
      None
    • Similar Issues:

      Description

      Some of contributors have recently reported that jenkins.io/hangout does not work for them reliably. Sometimes they get a permission error when they try to join the call. It was reported by Oliver Gondža, Martin d'Anjou, and several other contributors.

      I tested it on my own:

      • I can always connect using my corporate Google account ( onenashev at cloudbees dot com )
      • Sometimes I cannot join the call using my personal account as well.

      Firstly I assumed it is somehow related to a person who joins the meeting first. If it is a corporate Google account, it is not possible to join with GMail accounts anymore. But I was unable to reproduce it in such way

       

        Attachments

          Activity

          lloydchang Lloyd Chang added a comment -

          When issues occurred recently, what alternative(s) were used to continue the video-based group meetings?

          Perhaps Skype? Or WeChat? Maybe something else?

          Thank you.

          lloydchang Lloyd Chang added a comment -

          Hello everyone,

          When you cannot connect to jenkins.io/hangout with your Gmail account... On the same day, are you able to start or connect to a new Google hangout URL via these steps?
          1. Switch to your Gmail account
          2. Go to https://hangouts.google.com/call/
          3. Click "Copy Link to Share"
          4. Share the new link, e.g. https://hangouts.google.com/call/PkmbvkuZ5HbXDWy5X2v_AEEE

          I have a hypothesis that there were system-wide issues connecting Gmail and Google Hangout reliably in November, instead of an issue specific to jenkins.io/hangout only.

          On the same day (November 29th) when Oleg Nenashev created this bug report, I see a person unrelated to the Jenkins community reported following bug report, "not been able to use hangouts on my gmail accounts for hours" to Google:

          Hi, i've not been able to use hangouts on my gmail accounts for hours.

          by Rebecca Maxon Nov 29

          Hello please i cant use hangouts on my gmail account, it keeps showing something's not right,

          We're having trouble connecting to Google. We'll keep trying, Please kindly resolve this problem, thank you

          Categories:Gmail

          https://productforums.google.com/forum/#!topic/hangouts/1zAExNJA_wQ;context-place=topicsearchin/hangouts/connect%7Csort:date

          After skimming the Google Hangouts Help Forum, I see many reports of connection issues throughout November
          https://productforums.google.com/forum/#!topicsearchin/hangouts/connect%7Csort:date

          olblak Olivier Vernin added a comment -

          Which could make sense, thanks Lloyd Chang for your investigation.

          lloydchang Lloyd Chang added a comment - - edited

          (documenting an incident)
          At beginning of Dec-5 Wednesday 2pm UTC, GSoC meeting, this happened:
          1. Oleg Nenashev joined https://jenkins.io/hangout
          2. Lloyd Chang goes to https://jenkins.io/hangout
          3. Lloyd Chang was redirected to a "call" in URL  https://hangouts.google.com/call/-f0gw6h7DFaxzHXQgcT7AEEI?no_rd
          4. Lloyd Chang tries joining the call
          5. Google Hangout responds with:
          "Connecting... Error: You're not allowed to join this video call [CLOSE]"

          6. This video call ended because of an error

          7. Lloyd Chang reported the issue to https://gitter.im/jenkinsci/gsoc-sig
          8. To work around this issue, Oleg Nenashev creates a Hangout on Air (HoA) with the "hangouts" link of
          https://hangouts.google.com/hangouts/_/ytl/tlYihPj02ilylUIQvyJFfEl2rMTXXcPrumDHJycX6vQ=?eid=113711801835417391950&hl=en_US&authuser=1
          and shared the HoA link via Gitter
          9. Using the newly created HoA "hangouts" link, instead of a "call" in URL, worked around the error in above screenshot

          oleg_nenashev Oleg Nenashev added a comment -

          Hangouts on Air is dead, we are moving meetings to Zoom. I doubt we want to spend any time on that


            People

            • Assignee:
              Unassigned
              Reporter:
              oleg_nenashev Oleg Nenashev
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: