Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-2111

current/updates lists stale - cannot install newer version of Packer tool

    Details

    • Similar Issues:

      Description

      https://updates.jenkins.io/current/updates/ seems to be last updated on 18 April. 

      For me this causes issues with Packer plugin - I cannot install latest 1.4.1 version. Looking at current list I see it is outdated (latest version is 1.4.0): https://updates.jenkins.io/current/updates/biz.neustar.jenkins.plugins.packer.PackerInstaller.json

       

      Running crawler (https://github.com/jenkins-infra/crawler/blob/master/packer.groovy) manually generates a proper list:

      {"list": [
      {{ {}}
      {{ "id": "1.4.1-darwin-386",}}
      {{ "name": "Packer 1.4.1 darwin (386)",}}
      {{ "url": "https://releases.hashicorp.com/packer/1.4.1/packer_1.4.1_darwin_386.zip"}}
      {{ },}}
      {{ {}}
      {{ "id": "1.4.1-darwin-amd64",}}
      {{ "name": "Packer 1.4.1 darwin (amd64)",}}
      {{ "url": "https://releases.hashicorp.com/packer/1.4.1/packer_1.4.1_darwin_amd64.zip"}}
      {{ }, ...}}

        Attachments

          Activity

          Hide
          mmchr Mads Mohr Christensen added a comment -

          It looks like the crawler is updating again:

          biz.neustar.jenkins.plugins.packer.PackerInstaller.json 2019-05-31 14:10 149K 
          
          Show
          mmchr Mads Mohr Christensen added a comment - It looks like the crawler is updating again: biz.neustar.jenkins.plugins.packer.PackerInstaller.json 2019-05-31 14:10 149K 

            People

            • Assignee:
              Unassigned
              Reporter:
              mbochenk Nikita Bochenko
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: