Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10054

Build run on .../workspace@2 when option concurrent builds checked

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Debian GNU/Linux 5.0.3 (lenny)

      Description

      I think this issue might be related to this other one (in not the same):
      https://issues.jenkins-ci.org/browse/JENKINS-4202?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#issue-tabs

      The problem is reproducible when the "Execute concurrent builds if necessary" is enabled. Basically if there ia a build of a project running and a new one is enqueued in the same node, the enqueued build will create a new workspace named my-project-name@2/source, and at the end of the build it will report the following error:
      No test report files were found. Configuration error?
      Because there are no report files associated to that workspace.
      I think the problem is that the build is marked as successful as soon as the test task is finished, and then the next build is triggered. The issue is that the build which has just finished is still working on my-project-workspace because it has to generate the test results, that causes Jenkins to think that another project is using the workspace and it creates a new workspace my-project-name@2/
      Here is an example to make my point clear:
      [echo] Test Task Successfully Finished!
      BUILD SUCCESSFUL <--- here the build is marked as successful so a new build is triggered
      Total time: 52 minutes 5 seconds
      Recording test results <--- here the recently finished build is still working on the workspace, so the next build creates a new one
      Description set: hg parent: 2f6908ed61cc
      Finished: SUCCESS <--- at this point is when the build is Really finished and when the next one shall be triggered.

      To partially solve this issue, I configure the build to have 20 sec "quiet time" so that it will delay the next build and they won't overlap on the workspace usage. This doesn't work if builds are enqueued manually though, just when builds are triggered by SCM changes.

        Issue Links

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          I believe this is another manifestation of JENKINS-10615.


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              lorz88 Jose Mucientes
            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: