Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1016

NUnit: Problem with BuildStepCompatibilityLayer.perform

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I tried running Hudson v.156 as a Windows service, and got the following error
      which I havent seen before:

      java.lang.UnsupportedOperationException
      at
      hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:60)
      at hudson.plugins.nunit.NUnitPublisher.archive(NUnitPublisher.java:84)
      at hudson.plugins.nunit.NUnitArchiver.performJUnitArchiver(NUnitArchiver.java:137)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:90)
      at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:29)
      at hudson.FilePath.act(FilePath.java:291)
      at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:72)
      at
      hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:33)
      at hudson.model.Build$RunnerImpl.performAllBuildStep(Build.java:150)
      at hudson.model.Build$RunnerImpl.post2(Build.java:137)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:254)
      at hudson.model.Run.run(Run.java:667)
      at hudson.model.Build.run(Build.java:102)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:62)

        Attachments

          Activity

          redsolo redsolo added a comment -

          This problem was introduced in Hudson 150. v1.149 works fine as we were using it
          in our dev env. All releases after 150 would throw the below exception.

          redsolo redsolo added a comment -

          The problem is with BuildStepCompatibilityLayer.perform() which will throw the
          exception. The NUnit archiver should use the correct method when accesing JUnit

          redsolo redsolo added a comment -

          Fixed. The NUnit publisher now calls the correct method in JUnit archiver. This
          bug was introduced with the BuildStepCompabilityLayer in 1.150.


            People

            • Assignee:
              redsolo redsolo
              Reporter:
              redsolo redsolo
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: