Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10198

JUnit test results cannot be archived in jenkins 1.418

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: junit-plugin
    • Labels:
      None
    • Environment:
      Windows master, Linux slave

      Description

      I started receiving this failure after upgrading to 1.418. Reverting to 1.417 resolves the issue.

      00:09:59 ERROR: Failed to archive test reports
      00:09:59 hudson.util.IOException2: remote file operation failed: /<directory> at hudson.remoting.Channel@1bcff4d:<myserver>
      00:09:59 at hudson.FilePath.act(FilePath.java:754)
      00:09:59 at hudson.FilePath.act(FilePath.java:740)
      00:09:59 at hudson.tasks.junit.JUnitParser.parse(JUnitParser.java:83)
      00:09:59 at hudson.tasks.junit.JUnitResultArchiver.parse(JUnitResultArchiver.java:123)
      00:09:59 at hudson.tasks.junit.JUnitResultArchiver.perform(JUnitResultArchiver.java:135)
      00:09:59 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      00:09:59 at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:664)
      00:09:59 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:639)
      00:09:59 at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:617)
      00:09:59 at hudson.model.Build$RunnerImpl.post2(Build.java:161)
      00:09:59 at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:586)
      00:09:59 at hudson.model.Run.run(Run.java:1400)
      00:09:59 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      00:09:59 at hudson.model.ResourceController.execute(ResourceController.java:88)
      00:09:59 at hudson.model.Executor.run(Executor.java:146)
      00:09:59 Caused by: java.io.InvalidClassException: hudson.util.io.ParserConfigurator$1; local class incompatible: stream classdesc serialVersionUID = 6472613931861772577, local class serialVersionUID = -2178106894481500733
      00:09:59 at java.io.ObjectStreamClass.initNonProxy(Unknown Source)
      00:09:59 at java.io.ObjectInputStream.readNonProxyDesc(Unknown Source)
      00:09:59 at java.io.ObjectInputStream.readClassDesc(Unknown Source)
      00:09:59 at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
      00:09:59 at java.io.ObjectInputStream.readObject0(Unknown Source)
      00:09:59 at java.io.ObjectInputStream.readObject(Unknown Source)
      00:09:59 at hudson.remoting.UserRequest.deserialize(UserRequest.java:182)
      00:09:59 at hudson.remoting.UserRequest.perform(UserRequest.java:98)
      00:09:59 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      00:09:59 at hudson.remoting.Request$2.run(Request.java:283)
      00:09:59 at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      00:09:59 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      00:09:59 at java.util.concurrent.FutureTask.run(Unknown Source)
      00:09:59 at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      00:09:59 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      00:09:59 at java.lang.Thread.run(Unknown Source)
      00:09:59 Build step 'Publish JUnit test result report' changed build result to FAILURE

        Issue Links

          Activity

          sogabe sogabe added a comment -

          Did you update slave.jar?

          djs Dan Savilonis added a comment -

          I'm using ssh slaves, so it should always upload the correct slave.jar. Upon further review, the problem seems to be inconsistent. I'm no longer sure when it will work and when it will not. One thing that is clear is that archiving the test results does not work consistently in either 1.417 or 1.418.

          kutzi kutzi added a comment -

          Looks much more like a dup of JENKINS-10030 to me


            People

            • Assignee:
              Unassigned
              Reporter:
              djs Dan Savilonis
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: