Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10270

Git plugin advanced options disappear when you reopen the configuration screen

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      When you configure Advanced options in the git SCM section (e.g. 'Merge before build'), and save the changes, they are correctly stored. However, when you come back to the configuration screen and open the Advanced options again, 'Merge before build' is no longer checked and the configuration values are not displayed.

        Attachments

          Activity

          abayer Andrew Bayer added a comment -

          Confirmed with 1.1.9 - I think this is because of changes to how the merge options are stored. See https://github.com/jenkinsci/git-plugin/commit/2d37646c7fbac1687779ad62ffd4f1a8b0aae304

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Andrew Bayer
          Path:
          src/main/resources/hudson/plugins/git/GitSCM/config.jelly
          http://jenkins-ci.org/commit/git-plugin/200c8d931d0a8cd9f93d1e452bcbc1c70e147e25
          Log:
          [FIXED JENKINS-10270] Merge options persist properly now.

          dogfood dogfood added a comment -

          Integrated in plugins_git-plugin #194
          [FIXED JENKINS-10270] Merge options persist properly now.

          Andrew Bayer : 200c8d931d0a8cd9f93d1e452bcbc1c70e147e25
          Files :

          • src/main/resources/hudson/plugins/git/GitSCM/config.jelly

            People

            • Assignee:
              abayer Andrew Bayer
              Reporter:
              wakaleo John Smart
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: