Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10318

ConcurrentModificationException reading config.xml on startup

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Encountered the following error during startup. Some jobs do start, some jobs don't. Restarting hudson seems to solve the problemm.

      SEVERE: Failed Loading job job-58
      hudson.util.IOException2: Unable to read /data/hudson/workspace/jobs/job-58/config.xml
      at hudson.XmlFile.read(XmlFile.java:135)
      at hudson.model.Items.load(Items.java:114)
      at jenkins.model.Jenkins$14.run(Jenkins.java:2180)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:724)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
      ---- Debugging information ----
      cause-exception : java.util.ConcurrentModificationException
      cause-message : null
      class : hudson.model.FreeStyleProject
      required-type : hudson.util.DescribableList
      path : /project/publishers/hudson.tasks.Mailer
      line number : 64
      -------------------------------
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
      at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
      at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
      at hudson.util.XStream2.unmarshal(XStream2.java:84)
      at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
      at com.thoughtworks.xstream.XStream.fromXML(XStream.java:864)
      at hudson.XmlFile.read(XmlFile.java:131)
      ... 10 more
      Caused by: java.util.ConcurrentModificationException
      at java.util.TreeMap$PrivateEntryIterator.nextEntry(TreeMap.java:1100)
      at java.util.TreeMap$KeyIterator.next(TreeMap.java:1154)
      at com.thoughtworks.xstream.core.util.PrioritizedList$PrioritizedItemIterator.next(PrioritizedList.java:91)
      at com.thoughtworks.xstream.core.DefaultConverterLookup.lookupConverterForType(DefaultConverterLookup.java:62)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
      at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
      at hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:189)
      at hudson.util.DescribableList$ConverterImpl.unmarshal(DescribableList.java:245)
      at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
      ... 27 more

        Attachments

          Activity

          daehren David Ehrenberger added a comment -

          This occurring often on v1.487. Please elevate in priority.

          daehren David Ehrenberger added a comment -

          For what its worth, the following error looks to be related to a coverity publisher:


          Nov 2, 2012 9:23:25 AM jenkins.InitReactorRunner$1 onTaskFailed
          SEVERE: Failed Loading job Job.Coverity
          hudson.util.IOException2: Unable to read /jenkins/jobs/Job.Coverity/config.xml
          at hudson.XmlFile.read(XmlFile.java:141)
          at hudson.model.Items.load(Items.java:220)
          at jenkins.model.Jenkins$17.run(Jenkins.java:2507)
          at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
          at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
          at jenkins.model.Jenkins$7.runTask(Jenkins.java:883)
          at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
          at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
          at java.lang.Thread.run(Thread.java:662)
          Caused by: com.thoughtworks.xstream.converters.ConversionException: null : null
          ---- Debugging information ----
          cause-exception : java.util.ConcurrentModificationException
          cause-message : null
          class : hudson.model.FreeStyleProject
          required-type : jenkins.plugins.coverity.CoverityPublisher
          path : /project/publishers/jenkins.plugins.coverity.CoverityPublisher/invocationAssistance
          line number : 76
          -------------------------------
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:89)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
          at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
          at hudson.util.CopyOnWriteList$ConverterImpl.unmarshal(CopyOnWriteList.java:193)
          at hudson.util.DescribableList$ConverterImpl.unmarshal(DescribableList.java:263)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
          at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:332)
          at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:274)
          at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:221)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
          at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
          at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
          at hudson.util.XStream2.unmarshal(XStream2.java:103)
          at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
          at com.thoughtworks.xstream.XStream.fromXML(XStream.java:864)
          at hudson.XmlFile.read(XmlFile.java:137)
          ... 10 more
          Caused by: java.util.ConcurrentModificationException
          at java.util.TreeMap$PrivateEntryIterator.nextEntry(TreeMap.java:1100)
          at java.util.TreeMap$KeyIterator.next(TreeMap.java:1154)
          at com.thoughtworks.xstream.core.util.PrioritizedList$PrioritizedItemIterator.next(PrioritizedList.java:91)
          at com.thoughtworks.xstream.core.DefaultConverterLookup.lookupConverterForType(DefaultConverterLookup.java:62)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:66)
          at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:332)
          at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:274)
          at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:221)
          at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
          ... 33 more

          mika Michael Prokop added a comment -

          Does anyone of you have your jenkins data shared on NFS (or similar) maybe?

          Which plugins do you use?

          I was just referred to this bug report via JENKINS-16082 and I'm wondering what might be the actual underlying issue causing this problem for just some us of all the Jenkins users.

          danielbeck Daniel Beck added a comment -

          No responses to comment in over a year, so resolving as incomplete.

          If this issue happens on recent Jenkins versions, please file a new issue.


            People

            • Assignee:
              Unassigned
              Reporter:
              jessebrand Jesse Brand
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: