Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10354

Cannot start jenkins 1.421 - Glibc_2.11 not found

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
    • Similar Issues:
      Show 5 results

      Description

      Cannot start jenkins 1.421. When execute /etc/init.d/jenkins start I have the following exception:
      Starting Jenkins Exception in thread "main" java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at Main._main(Main.java:125)
      at Main.main(Main.java:95)
      Caused by: java.lang.UnsatisfiedLinkError: /tmp/jna/jna2123156991551141605.tmp: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /tmp/jna/jna2123156991551141605.tmp)
      at java.lang.ClassLoader$NativeLibrary.load(Native Method)
      at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750)
      at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1646)
      at java.lang.Runtime.load0(Runtime.java:787)
      at java.lang.System.load(System.java:1022)
      at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:745)
      at com.sun.jna.Native.loadNativeLibrary(Native.java:674)
      at com.sun.jna.Native.<clinit>(Native.java:115)
      at com.sun.akuma.CLibrary.<clinit>(CLibrary.java:54)
      at com.sun.akuma.JavaVMArguments.resolvePID(JavaVMArguments.java:103)
      at com.sun.akuma.JavaVMArguments.ofLinux(JavaVMArguments.java:91)
      at com.sun.akuma.JavaVMArguments.of(JavaVMArguments.java:81)
      at com.sun.akuma.JavaVMArguments.current(JavaVMArguments.java:69)
      at com.sun.akuma.Daemon.daemonize(Daemon.java:77)
      at com.sun.akuma.Daemon.all(Daemon.java:59)
      ... 6 more

      and jenkins doesn't start.

      Jenkins 1.420 works without problems.

      [root@integration ~]# /lib64/libc.so.6
      GNU C Library stable release version 2.5, by Roland McGrath et al.
      Copyright (C) 2006 Free Software Foundation, Inc.
      This is free software; see the source for copying conditions.
      There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
      PARTICULAR PURPOSE.
      Compiled by GNU CC version 4.1.2 20080704 (Red Hat 4.1.2-50).
      Compiled on a Linux 2.6.9 system on 2011-06-27.
      Available extensions:
      The C stubs add-on version 2.1.2.
      crypt add-on version 2.1 by Michael Glad and others
      GNU Libidn by Simon Josefsson
      GNU libio by Per Bothner
      NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
      Native POSIX Threads Library by Ulrich Drepper et al
      BIND-8.2.3-T5B
      RT using linux kernel aio
      Thread-local storage support included.
      For bug reporting instructions, please see:
      <http://www.gnu.org/software/libc/bugs.html>.

        Attachments

          Activity

          afischer Alexander Fischer added a comment -

          I had the same problems after updating to Jenkins 1.421 on a CentOS5.6 (64bit). I have to rollback to 1.420...

          miked michael d added a comment - - edited

          I have the same problem

           
          sudo /etc/init.d/jenkins start
          Starting Jenkins Exception in thread "main" java.lang.reflect.InvocationTargetException
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                  at java.lang.reflect.Method.invoke(Method.java:597)
                  at Main._main(Main.java:125)
                  at Main.main(Main.java:95)
          Caused by: java.lang.UnsatisfiedLinkError: /tmp/jna/jna4144139455713645224.tmp: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /tmp/jna/jna4144139455713645224.tmp)
                  at java.lang.ClassLoader$NativeLibrary.load(Native Method)
                  at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
                  at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
                  at java.lang.Runtime.load0(Runtime.java:770)
                  at java.lang.System.load(System.java:1003)
                  at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:745)
                  at com.sun.jna.Native.loadNativeLibrary(Native.java:674)
                  at com.sun.jna.Native.<clinit>(Native.java:115)
                  at com.sun.akuma.CLibrary.<clinit>(CLibrary.java:54)
                  at com.sun.akuma.JavaVMArguments.resolvePID(JavaVMArguments.java:103)
                  at com.sun.akuma.JavaVMArguments.ofLinux(JavaVMArguments.java:91)
                  at com.sun.akuma.JavaVMArguments.of(JavaVMArguments.java:81)
                  at com.sun.akuma.JavaVMArguments.current(JavaVMArguments.java:69)
                  at com.sun.akuma.Daemon.daemonize(Daemon.java:77)
                  at com.sun.akuma.Daemon.all(Daemon.java:59)
                  ... 6 more
                                                                     [FAILED]
          

          and also

           
          [jenkins@ord-hud01 ~]$ uname -a
          Linux ord-hud01 2.6.18-194.el5 #1 SMP Tue Mar 16 21:52:39 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
          [jenkins@ord-hud01 ~]$ cat /etc/redhat-release
          Red Hat Enterprise Linux Server release 5.5 (Tikanga)
          [jenkins@ord-hud01 ~]$ cat /proc/version
          Linux version 2.6.18-194.el5 (mockbuild@x86-005.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Tue Mar 16 21:52:39 EDT 2010
          [jenkins@ord-hud01 ~]$
          

          my plugins:

           
          [Plugin:cvs, Plugin:claim, Plugin:maven-plugin, Plugin:subversion, Plugin:thinBackup, Plugin:clone-workspace-scm, Plugin:email-ext, Plugin:jobConfigHistory, Plugin:role-strategy, Plugin:setenv, Plugin:htmlpublisher, Plugin:copyartifact, Plugin:ssh-slaves]
          
           
          [jenkins@ord-hud01 ~]$ rpm -qa | grep glibc
          glibc-2.5-49
          compat-glibc-2.3.4-2.26
          glibc-devel-2.5-49
          glibc-headers-2.5-49
          glibc-2.5-49
          glibc-devel-2.5-49
          compat-glibc-2.3.4-2.26
          compat-glibc-headers-2.3.4-2.26
          glibc-common-2.5-49
          
           
          [jenkins@ord-hud01 ~]$ java -version
          java version "1.6.0_25"
          Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
          Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)
          
          smerrill Steven Merrill added a comment -

          Same problem, also on CentOS 5.6.

          sudo /sbin/service jenkins start
          Starting Jenkins Exception in thread "main" java.lang.reflect.InvocationTargetException
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:616)
          at Main._main(Main.java:125)
          at Main.main(Main.java:95)
          Caused by: java.lang.UnsatisfiedLinkError: /tmp/jna/jna3104052741036611210.tmp: /lib64/libc.so.6: version `GLIBC_2.11' not found (required by /tmp/jna/jna3104052741036611210.tmp)
          at java.lang.ClassLoader$NativeLibrary.load(Native Method)
          at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750)
          at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1646)
          at java.lang.Runtime.load0(Runtime.java:787)
          at java.lang.System.load(System.java:1022)
          at com.sun.jna.Native.loadNativeLibraryFromJar(Native.java:745)
          at com.sun.jna.Native.loadNativeLibrary(Native.java:674)
          at com.sun.jna.Native.<clinit>(Native.java:115)
          at com.sun.akuma.CLibrary.<clinit>(CLibrary.java:54)
          at com.sun.akuma.JavaVMArguments.resolvePID(JavaVMArguments.java:103)
          at com.sun.akuma.JavaVMArguments.ofLinux(JavaVMArguments.java:91)
          at com.sun.akuma.JavaVMArguments.of(JavaVMArguments.java:81)
          at com.sun.akuma.JavaVMArguments.current(JavaVMArguments.java:69)
          at com.sun.akuma.Daemon.daemonize(Daemon.java:77)
          at com.sun.akuma.Daemon.all(Daemon.java:59)
          ... 6 more

          prenaud76 Patrick Renaud added a comment -

          Same happens with the Restart Safely plugin under 1.421. Rolling back...

          kutzi kutzi added a comment -

          There were changes to the JNA library in JENKINS-9486.
          Assigning to Kohsuke

          kohsuke Kohsuke Kawaguchi added a comment - - edited

          Please report your Linux environment/distribution/version so that I can see what platforms this is affecting.

          Also, JVM version and whether that's 32bit/64bit please.

          daniele_antonini Daniele Antonini added a comment -

          [root@integration ~]# uname -a
          Linux integration 2.6.18-238.12.1.el5 #1 SMP Tue May 31 13:22:04 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
          [root@integration ~]# cat /etc/redhat-release
          CentOS release 5.6 (Final)
          [root@integration ~]# cat /proc/version
          Linux version 2.6.18-238.12.1.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Tue May 31 13:22:04 EDT 2011

          do you need of other infos?

          spfister1 Scott Pfister added a comment - - edited

          Another victim, sharing details of the crime scene:

          [root@cisllm01-tx jenkins]# uname -a
          Linux cisllm01-tx 2.6.18-238.el5 #1 SMP Sun Dec 19 14:22:44 EST 2010 x86_64 x86_64 x86_64 GNU/Linux
          
          [root@cisllm01-tx jenkins]# cat /etc/redhat-release 
          Red Hat Enterprise Linux Server release 5.6 (Tikanga)
          
          [root@cisllm01-tx jenkins]# /usr/bin/java -version
          java version "1.6.0_25"
          Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
          Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)
          

          Reverted back to former version without a problem.

          markdoliner Mark Doliner added a comment -

          I also started experiencing this problem with 1.421. Also using CentOS 5.6 on x86_64.

          Using a java 1.6.0 package from the JPackage project:
          $ /usr/lib/jvm/java-1.6.0/bin/java -version
          java version "1.6.0_22"
          Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
          Java HotSpot(TM) 64-Bit Server VM (build 17.1-b03, mixed mode)

          If it helps, the problem goes away if I remove "--daemon" from the Jenkins command line in /etc/init.d/jenkins.

          daniele_antonini Daniele Antonini added a comment -

          sorry I forgot java version.
          [root@integration ~]# java -version
          java version "1.6.0_17"
          Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
          Oracle JRockit(R) (build R28.0.0-679-130297-1.6.0_17-20100312-2121-linux-x86_64, compiled mode)

          metavida Marcos Wright-Kuhns added a comment -

          Same problem here. Below is server info:

          [root@matsuo /]# uname -a
          Linux ... 2.6.24-19-xen #1 SMP Wed Aug 20 21:08:51 UTC 2008 x86_64 x86_64 x86_64 GNU/Linux
          [root@matsuo /]# cat /etc/redhat-release 
          CentOS release 5.6 (Final)
          [root@matsuo /]# cat /proc/version
          Linux version 2.6.24-19-xen (buildd@king) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Wed Aug 20 21:08:51 UTC 2008
          [root@matsuo /]# java -version
          java version "1.6.0_20"
          OpenJDK Runtime Environment (IcedTea6 1.9.8) (rhel-1.22.1.9.8.el5_6-x86_64)
          OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
          
          markdoliner Mark Doliner added a comment -

          Hmm, since the error message references glibc, maybe we should include what version of glibc we're using? I have:
          glibc-2.5-58.el5_6.4

          kimrru Kim Russell added a comment - - edited

          Please also consider

          MGMT1[~]> uname -a
          Linux ..... 2.6.18-194.17.4.el5 #1 SMP Wed Oct 20 13:03:08 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
          MGMT1[~]> cat /etc/redhat-release
          Red Hat Enterprise Linux Server release 5.6 (Tikanga)
          MGMT1[~]> cat /proc/version
          Linux version 2.6.18-194.17.4.el5 (mockbuild@x86-005.build.bos.redhat.com) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-48)) #1 SMP Wed Oct 20 13:03:08 EDT 2010
          MGMT1[~]> java -version
          java version "1.6.0_20"
          OpenJDK Runtime Environment (IcedTea6 1.9.8) (rhel-1.22.1.9.8.el5_6-x86_64)
          OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)
          MGMT1[~]> rpm -qa | grep glibc
          glibc-2.5-58.el5_6.4
          glibc-common-2.5-58.el5_6.4
          glibc-devel-2.5-58.el5_6.4
          glibc-2.5-58.el5_6.4
          glibc-headers-2.5-58.el5_6.4

          afischer Alexander Fischer added a comment -

          Hello,

          my environment with these problems is:
          --> java -version
          java version "1.6.0_25"
          Java(TM) SE Runtime Environment (build 1.6.0_25-b06)
          Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode)

          --> cat /proc/version
          Linux version 2.6.18-238.12.1.el5 (mockbuild@builder10.centos.org) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-50)) #1 SMP Tue May 31 13:22:04 EDT 2011
          --> cat /etc/redhat-release
          CentOS release 5.6 (Final)

          --> rpm -qa | grep glibc
          glibc-2.5-58.el5_6.4
          glibc-2.5-58.el5_6.4
          glibc-common-2.5-58.el5_6.4

          kimrru Kim Russell added a comment -

          I've found that reverting back a version helps. I did that yesterday and again this morning when it automatically updated. Jenkins is on my exclude list until this error is resolved.

          bigworld BigWorld Build Engineer added a comment -

          We are also experiencing this issue:

          CentOS 5.6 (x86_64)

          glibc is installed from the base centos yum repo.

          Installed Packages
          Name : glibc
          Version : 2.5

          java is installed from the rpms on java.sun.com.
          Installed Packages
          Name : jre
          Version : 1.6.0_26

          rpetti Rob Petti added a comment - - edited

          Here are some of my findings, because I'm bored...

          I've narrowed it down to this change being the culprit using git bisect:

          9b0c8d236257ec32b052875921bd22e3f9ac7416 is the first bad commit
          commit 9b0c8d236257ec32b052875921bd22e3f9ac7416
          Author: Kohsuke Kawaguchi <kk@kohsuke.org>
          Date: Sun Jul 10 12:06:57 2011 -0700

          [FIXED JENKINS-9486] integrated a patched version of JNA that includes a fix for JNA-184

          I also noticed that running it using java -jar jenkins.war works fine, even with a 'broken' version. After digging into it, it looks like the error is only reproducible when passing the --daemon flag to jenkins, like the init.d script does. I'm guessing that's because --daemon signals Jenkins to run fork() or some other system-level function.

          On an unrelated note, the init.d script also selected the incorrect jre. Rather than pointing to /usr/bin/java, which is the symlink maintained by the alternatives system, it chose OpenJRE. I tried both Open and Sun versions of java, and it doesn't look like it made any difference as far as this issue is concerned.

          lflux Ian Delahorne added a comment -

          Getting the same error here, Centos 5.5, glibc-2.5-49.el5_5.7, java-1.6.0-openjdk-1.6.0.0-1.16.b17.el5. As before, reverting back to 1.420 works.

          jkellerer Jürgen Kellerer added a comment - - edited

          It is all related to the JNA version 3.3.0. Downgrading it to 3.2.4 (as it used to be in 1.420) solves the issue. GLIBC in CentOS is quite old.

          kohsuke Kohsuke Kawaguchi added a comment -

          I suspect I ended up recompiling the shared library portion (whereas I only needed to recompile the Java portion.) My hypothesis is that this somehow created dependency to GLIBC 2.11.

          Digging deeper to reproduce & verify.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/pom.xml
          http://jenkins-ci.org/commit/jenkins/6b4f9bc385be172be7eb4dd00e20e64a5abf316f
          Log:
          [FIXED JENKINS-10354] integrated a rebuilt JNA jar

          Compare: https://github.com/jenkinsci/jenkins/compare/982d563...6b4f9bc

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          http://jenkins-ci.org/commit/jenkins/d4c379ed8f7169b1475e54efd648fa6d2b7d3a83
          Log:
          recording JENKINS-10354

          kohsuke Kohsuke Kawaguchi added a comment -

          Verified the hypothesis and fixed it in 1.422.

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #974
          [FIXED JENKINS-10354] integrated a rebuilt JNA jar
          recording JENKINS-10354

          Kohsuke Kawaguchi : 6b4f9bc385be172be7eb4dd00e20e64a5abf316f
          Files :

          • core/pom.xml

          Kohsuke Kawaguchi : d4c379ed8f7169b1475e54efd648fa6d2b7d3a83
          Files :

          • changelog.html
          markdoliner Mark Doliner added a comment -

          I just yum updated to the 1.423-1.1 RPM and it's working great.

          Thanks for dealing with this, Kohsuke! We appreciate all your work over the years!

          daniele_antonini Daniele Antonini added a comment -

          Jenkins 1.423-1.1 works fine. Thanks for the fix!

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/pom.xml
          http://jenkins-ci.org/commit/jenkins/6b4f9bc385be172be7eb4dd00e20e64a5abf316f
          Log:
          [FIXED JENKINS-10354] integrated a rebuilt JNA jar

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          http://jenkins-ci.org/commit/jenkins/d4c379ed8f7169b1475e54efd648fa6d2b7d3a83
          Log:
          recording JENKINS-10354

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/pom.xml
          http://jenkins-ci.org/commit/jenkins/6b4f9bc385be172be7eb4dd00e20e64a5abf316f
          Log:
          [FIXED JENKINS-10354] integrated a rebuilt JNA jar

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          changelog.html
          http://jenkins-ci.org/commit/jenkins/d4c379ed8f7169b1475e54efd648fa6d2b7d3a83
          Log:
          recording JENKINS-10354


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              daniele_antonini Daniele Antonini
            • Votes:
              11 Vote for this issue
              Watchers:
              20 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: