Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10379

Allowed statuses for Klocwork report are incorrect

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: klocwork-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.421 on RHEL 5.2, Klocwork 9.2.2, Klocwork plugin
    • Similar Issues:

      Description

      When trying to parse Klocwork 9.2.2 report, an error is raised:
      At line 25 of file:/tmp/workspace/job1/kwreport.xml:cvc-enumeration-valid: Value 'Not a Problem' is not facet-valid with respect to enumeration '[Analyze, Ignore, Not a problem, Fix, Fix in Next Release, Fix in Later Release, Defer, Filter]'. It must be a value from the enumeration.

      kwreport.xml comes straight from kwinspectreport 9.2.2.

      [I know it's not a core issue, but there's no klocwork component]

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Could you attach your Klocwork report?

          raspy Krzysztof Malinowski added a comment -

          Attached Klocwork report illustrating problem. Note that status is 'Not a Problem' and not 'Not a problem'.

          gbois Gregory Boissinot added a comment -

          The issue is not fixed. Do not close it

          raspy Krzysztof Malinowski added a comment -

          Err... The issue state has been "Fixed" for more than two months now and no longer reproduces at my installation. So how exactly is it not fixed?


            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              raspy Krzysztof Malinowski
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: