Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10472

clodubees-deploy-plugin's MavenArtifactFilePathSaver does not check if the Publisher is enabled

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      org.jenkins.plugins.cloudbees.MavenArtifactFilePathSaver can break Maven builds even when the cloudbees-deployer plugin is not enabled for a certain build. For instance, I'm getting the following exception for a build:

      https://gist.github.com/1109680

      I think the solution is for this reporter to verify that the parent MavenModuleSet has the CloudbeesPublisher enabled.

        Attachments

          Activity

          Hide
          dogfood dogfood added a comment -

          Integrated in plugins_cloudbees-deployer-plugin #22
          [FIXED JENKINS-10472] take care of builds which don't produce artifacts

          Olivier Lamy :
          Files :

          • src/main/java/org/jenkins/plugins/cloudbees/MavenArtifactFilePathSaver.java
          Show
          dogfood dogfood added a comment - Integrated in plugins_cloudbees-deployer-plugin #22 [FIXED JENKINS-10472] take care of builds which don't produce artifacts Olivier Lamy : Files : src/main/java/org/jenkins/plugins/cloudbees/MavenArtifactFilePathSaver.java
          Hide
          olamy Olivier Lamy added a comment -

          reopen as not really fixed

          Show
          olamy Olivier Lamy added a comment - reopen as not really fixed
          Hide
          pascalleclercq pascalleclercq added a comment -

          Hi Olivier,
          as you suggest I complete here.
          https://github.com/olamy/cloudbees-deployer-plugin/issues/2

          I'm sorry to say I miss time for a correct answer but may issue is probably related.

          I will be off for 2 weeks stating today.

          Please let me know how I can test, I can only reproduce the problem on cloudbees and I can't upgrade the plugin.

          Thx again

          Show
          pascalleclercq pascalleclercq added a comment - Hi Olivier, as you suggest I complete here. https://github.com/olamy/cloudbees-deployer-plugin/issues/2 I'm sorry to say I miss time for a correct answer but may issue is probably related. I will be off for 2 weeks stating today. Please let me know how I can test, I can only reproduce the problem on cloudbees and I can't upgrade the plugin. Thx again
          Hide
          pascalleclercq pascalleclercq added a comment -

          Just tested here :

          https://opensagres.ci.cloudbees.com/job/xdocreport/

          It works like a charm now.

          Thx !

          Show
          pascalleclercq pascalleclercq added a comment - Just tested here : https://opensagres.ci.cloudbees.com/job/xdocreport/ It works like a charm now. Thx !
          Hide
          olamy Olivier Lamy added a comment -

          not used anymore

          Show
          olamy Olivier Lamy added a comment - not used anymore

            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              recampbell Ryan Campbell
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: