Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10486

Git plugin doesn't limit polling/checkout of repo to specific branch

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins v1.421, Git plugin v1.1.10
    • Similar Issues:

      Description

      We have a build against the repo at https://github.com/aptana/studio3-ruby, where we've specified "origin/development" as the "Branches to build".

      However, now it's picking up commits on origin/master. Here's the beginning of a bad build:

      Started by upstream project "studio3-core-development" build number 1607
      Building remotely on hudson-ubuntu1
      Checkout:studio3-ruby-development / /var/hudson/workspace/studio3-ruby-development - hudson.remoting.Channel@1d5e778:hudson-ubuntu1
      Using strategy: Default
      Last Built Revision: Revision 21fca4614c426857b71cb60cec448bd3a0679653 (origin/development)
      Checkout:studio3-ruby-development / /var/hudson/workspace/studio3-ruby-development - hudson.remoting.LocalChannel@1a43cda
      Wiping out workspace first.
      Cloning the remote Git repository
      Cloning repository origin
      Fetching upstream changes from git://github.com/aptana/studio3-ruby.git
      Cleaning workspace
      Commencing build of Revision 1a0bfdade287d963921953fcb0c82d36d08f5368 (origin/development)
      Checking out Revision 1a0bfdade287d963921953fcb0c82d36d08f5368 (origin/development)
      Cleaning workspace
      

      The revision pointed at there is actually on origin/master: https://github.com/aptana/studio3-ruby/commit/1a0bfdade287d963921953fcb0c82d36d08f5368

      While the latest HEAD for origin/development is https://github.com/aptana/studio3-ruby/commit/21fca4614c426857b71cb60cec448bd3a0679653

        Attachments

          Issue Links

            Activity

            seadub Chris Williams added a comment -

            Hmm, looks like a duplicate of JENKINS-10408


              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                seadub Chris Williams
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: