Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10502

Add an option to make archiving the artifacts non-fatal if they don't exist

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins 1.421
    • Similar Issues:

      Description

      If you tick the box to enable "Archive the artifacts", populate the "Files to archive", and your build fails to output those artifacts it will fail with something like this:

      12:11:51  Archiving artifacts
      12:11:51  ERROR: No artifacts found that match the file pattern "tfields/Live/Engine/Tools/Layout.*". Configuration error?
      12:11:57  ERROR: 'tfields/Live/Engine/Tools/Layout.*' doesn't match anything: 'tfields' exists but not 'tfields/Live/Engine/Tools/Layout.*'
      12:11:57  Build step 'Archive the artifacts' changed build result to FAILURE
      

      Depending on what your build actually does, those artifacts might not always be created. I'd like to propose that you add an option to make the archiving of artifacts non fatal.

      Thanks,
      Tom.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            core/src/main/java/hudson/tasks/ArtifactArchiver.java
            core/src/main/resources/hudson/tasks/ArtifactArchiver/config.jelly
            core/src/main/resources/hudson/tasks/ArtifactArchiver/config.properties
            core/src/main/resources/hudson/tasks/ArtifactArchiver/help-allowEmptyArchive.html
            test/src/test/groovy/hudson/matrix/MatrixProjectTest.groovy
            test/src/test/java/hudson/model/AbstractProjectTest.java
            test/src/test/java/hudson/tasks/ArtifactArchiverTest.java
            test/src/test/java/hudson/tasks/LogRotatorTest.java
            http://jenkins-ci.org/commit/jenkins/aeb887c12d60987745ed40a55d0f6ddcee503426
            Log:
            Merge pull request #732 from pjrt/JENKINS-10502

            [FIXED JENKINS-10502] Option to make the build not fail if there is nothing to archive

            Compare: https://github.com/jenkinsci/jenkins/compare/77e011a3dae3...aeb887c12d60


            You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
            For more options, visit https://groups.google.com/groups/opt_out.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/e88932956f78dc8c89835256b820cca671756286
            Log:
            JENKINS-10502 Noting.

            Compare: https://github.com/jenkinsci/jenkins/compare/aeb887c12d60...e88932956f78


            You received this message because you are subscribed to the Google Groups "Jenkins Commits" group.
            To unsubscribe from this group and stop receiving emails from it, send an email to jenkinsci-commits+unsubscribe@googlegroups.com.
            For more options, visit https://groups.google.com/groups/opt_out.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2381
            JENKINS-10502 Option to make the build NOT fail if there is nothing to archive (Revision d3096819f6a70c107399fbcf2df23718098c926e)
            JENKINS-10502 Noting. (Revision e88932956f78dc8c89835256b820cca671756286)

            Result = SUCCESS
            pjrodriguezt : d3096819f6a70c107399fbcf2df23718098c926e
            Files :

            • test/src/test/java/hudson/tasks/ArtifactArchiverTest.java
            • test/src/test/java/hudson/model/AbstractProjectTest.java
            • core/src/main/java/hudson/tasks/ArtifactArchiver.java
            • core/src/main/resources/hudson/tasks/ArtifactArchiver/config.properties
            • core/src/main/resources/hudson/tasks/ArtifactArchiver/config.jelly
            • test/src/test/java/hudson/tasks/LogRotatorTest.java

            Jesse Glick : e88932956f78dc8c89835256b820cca671756286
            Files :

            • changelog.html
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/98869558a3c7b6183c60f492153b45384dd36db5
            Log:
            JENKINS-10502 This was an RFE, not a bug.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #2386
            JENKINS-10502 This was an RFE, not a bug. (Revision 98869558a3c7b6183c60f492153b45384dd36db5)

            Result = SUCCESS
            Jesse Glick : 98869558a3c7b6183c60f492153b45384dd36db5
            Files :

            • changelog.html

              People

              • Assignee:
                nacht Pedro Rodriguez
                Reporter:
                tfields Thomas Fields
              • Votes:
                16 Vote for this issue
                Watchers:
                22 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: