Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10511

Autoinstall JDK from java.sun.com no longer works

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:
      Show 5 results

      Description

      Just noticed that the autoinstallation of JDK from java.sun.com stopped working recently. I tried various Jenkins instances running here and they all have the same problem; versions from 1.415 to 1.423 on Linux.

        Attachments

          Issue Links

            Activity

            robertdw robertdw added a comment -

            Echoing dhaun - is this going to be backported?

            vjuranek vjuranek added a comment -

            yes, this should be backported to 1.409.2, which should be available in 2-3 weeks

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/cb2ced734edc6ace59f5efd8dadbdaed0588a90d
            Log:
            [FIXED JENKINS-10511] commits leading up to this is for making JDK installer work again

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Kohsuke Kawaguchi
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/cb2ced734edc6ace59f5efd8dadbdaed0588a90d
            Log:
            [FIXED JENKINS-10511] commits leading up to this is for making JDK installer work again

            chinolatte Matt D added a comment -

            I'm on version 1.430 and I still get the same error no matter what I do with proxy settings:

            Installing JDK jdk-6u20-oth-JPR
            Downloading JDK from http://download.oracle.com/otn/java/jdk/6u20-b02//jdk-6u20-linux-x64.bin
            FATAL: GET http://download.oracle.com/otn/java/jdk/6u20-b02//jdk-6u20-linux-x64.bin failed
            java.io.IOException: GET http://download.oracle.com/otn/java/jdk/6u20-b02//jdk-6u20-linux-x64.bin failed
            at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:126)
            at com.gargoylesoftware.htmlunit.WebClient.loadWebResponseFromWebConnection(WebClient.java:1456)
            at com.gargoylesoftware.htmlunit.WebClient.loadWebResponse(WebClient.java:1387)
            at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:328)
            at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:389)
            at hudson.tools.JDKInstaller.locate(JDKInstaller.java:349)
            at hudson.tools.JDKInstaller.performInstallation(JDKInstaller.java:120)
            at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:61)
            at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:107)
            at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:150)
            at hudson.model.JDK.forNode(JDK.java:112)
            at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:821)
            at hudson.tasks.Maven.perform(Maven.java:211)
            at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:693)
            at hudson.model.Build$RunnerImpl.build(Build.java:178)
            at hudson.model.Build$RunnerImpl.doRun(Build.java:139)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:459)
            at hudson.model.Run.run(Run.java:1376)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:230)
            Caused by: java.net.ConnectException: Connection timed out
            at java.net.PlainSocketImpl.socketConnect(Native Method)
            at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
            at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
            at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
            at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
            at java.net.Socket.connect(Socket.java:519)
            at java.net.Socket.connect(Socket.java:469)
            at java.net.Socket.<init>(Socket.java:366)
            at java.net.Socket.<init>(Socket.java:240)
            at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:80)
            at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:122)
            at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
            at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
            at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
            at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
            at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
            at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
            at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:97)
            ... 21 more


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                prenaud76 Patrick Renaud
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: