Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10575

git plugin does not support / in branch names

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      git plugin 1.1.9, jenkins 1.423
    • Similar Issues:

      Description

      To reproduce:

      • Set up a job that checks out a project from git
      • Set "Branches to build" specifier to something/somethingelse (that's valid in your git project)
      • Try to build

      This gives me the following error:
      ERROR: Couldn't find any revision to build. Verify the repository and branch configuration for this job.

      Doing the following makes the job build fine:

      • git checkout -b something-somethingelse something/something else
      • git push origin something-somethingelse
      • Set "Branches to build" specifier to something-somethingelse

        Attachments

          Issue Links

            Activity

            jorgenpt Jørgen Tjernø created issue -
            jorgenpt Jørgen Tjernø made changes -
            Field Original Value New Value
            Description To reproduce:
            * Set up a job that checks out a project from git
            * Set "Branches to build" specifier to {{something/somethingelse}} (that's valid in your git project)
            * Try to build

            This gives me the following error:
            {{ERROR: Couldn't find any revision to build. Verify the repository and branch configuration for this job.}}
            To reproduce:
            * Set up a job that checks out a project from git
            * Set "Branches to build" specifier to {{something/somethingelse}} (that's valid in your git project)
            * Try to build

            This gives me the following error:
            {{ERROR: Couldn't find any revision to build. Verify the repository and branch configuration for this job.}}

            Doing the following makes the job build fine:
            * git checkout -b something-somethingelse something/something else
            * git push origin something-somethingelse
            * Set "Branches to build" specifier to {{something-somethingelse}}
            abayer Andrew Bayer added a comment -

            Try origin/something/somethingelse - if it just sees one /, it's going to take the first part as the remote and get confused.

            mikij Milutin Jovanovic added a comment -

            A workaroung that works for me is to spacify two branches to build, first master and then the one I actually want to build. Interestingly, only one branch is built this way, the second one.

            kostmo Karl Ostmo made changes -
            Link This issue duplicates JENKINS-14026 [ JENKINS-14026 ]
            ndeloof Nicolas De Loof added a comment -

            using / in branch name is a bad idea as it's confusing with remote name. To disambiguate, need to always set <remote>/<branchnamemaybewithslash>

            ndeloof Nicolas De Loof made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Assignee abayer [ abayer ] Nicolas De Loof [ ndeloof ]
            Resolution Won't Fix [ 2 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 140769 ] JNJira + In-Review [ 189245 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                jorgenpt Jørgen Tjernø
              • Votes:
                2 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: