Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10634

Proxy settings arent used by JDK-downloader

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: javanet-plugin
    • Labels:
    • Environment:
      Linux SLES11
    • Similar Issues:
      Show 5 results

      Description

      When we automatically install the jdk by hudson we get a host not found exception.
      If we use wget locally (http_proxy ist set) everthing is working fine.

        Attachments

          Activity

          danrussell dan russell added a comment -

          Using 1.424 and 1.426 we have a similar issue. Both on windows and unix nodes it fails to download a jdk with connection refused exception.

          On a unix node, when Jenkins tries to download http://download.oracle.com/otn-pub/java/jdk/6u26-b03//jdk-6u26-linux-i586.bin it gets a connection refused exception.

          When using execute shell in a job on the same node with wget http://download.oracle.com/otn-pub/java/jdk/6u26-b03//jdk-6u26-linux-i586.bin it will start to download the jdk.

          I have also tried to set the java_opts to pass in http.proxyPort and http.proxyHost but it still threw the same exception.

          Installing JDK jdk-6u26-oth-JPR
          Downloading JDK from http://download.oracle.com/otn-pub/java/jdk/6u26-b03//jdk-6u26-linux-i586.bin
          java.io.IOException: GET http://download.oracle.com/otn-pub/java/jdk/6u26-b03//jdk-6u26-linux-i586.bin failed
          at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:126)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponseFromWebConnection(WebClient.java:1456)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponse(WebClient.java:1387)
          at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:328)
          at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:389)
          at hudson.tools.JDKInstaller.locate(JDKInstaller.java:350)
          at hudson.tools.JDKInstaller.performInstallation(JDKInstaller.java:121)
          at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:61)
          at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:107)
          at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:150)
          at hudson.model.JDK.forNode(JDK.java:112)
          at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:796)
          at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:651)
          at hudson.model.AbstractProject.checkout(AbstractProject.java:1193)
          at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:555)
          at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:443)
          at hudson.model.Run.run(Run.java:1376)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:230)
          Caused by: java.net.ConnectException: Connection refused
          at java.net.PlainSocketImpl.socketConnect(Native Method)
          at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
          at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
          at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
          at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
          at java.net.Socket.connect(Socket.java:529)
          at java.net.Socket.connect(Socket.java:478)
          at java.net.Socket.<init>(Socket.java:375)
          at java.net.Socket.<init>(Socket.java:249)
          at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:80)
          at org.apache.commons.httpclient.protocol.DefaultProtocolSocketFactory.createSocket(DefaultProtocolSocketFactory.java:122)
          at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
          at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
          at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
          at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
          at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
          at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
          at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:97)
          ... 19 more

          danrussell dan russell added a comment -

          The changes to support oracle have changed from using the ProxyConfiguration class which used proxy settings to WebClient without setting the proxy or port details.

          https://github.com/jenkinsci/jenkins/blob/master/core/src/main/java/hudson/tools/JDKInstaller.java

          Line 346
          WebClient wc = new WebClient();

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Andrew Bradley
          Path:
          changelog.html
          core/src/main/java/hudson/tools/JDKInstaller.java
          http://jenkins-ci.org/commit/jenkins/fa00cd25296af0b1958be8d55a787a585b18e3e0
          Log:
          [FIXED JENKINS-10634] JDK downloader now uses Jenkins proxy settings

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #1133
          [FIXED JENKINS-10634] JDK downloader now uses Jenkins proxy settings

          Kohsuke Kawaguchi : fa00cd25296af0b1958be8d55a787a585b18e3e0
          Files :

          • changelog.html
          • core/src/main/java/hudson/tools/JDKInstaller.java
          prenaud76 Patrick Renaud added a comment - - edited

          Still not working, on 1.432. Our proxy settings aren't using username/password. This is what I get:

          Started by user anonymous
          Building remotely on ecamolx0404
          Installing JDK jdk-6u26-oth-JPR
          Downloading JDK from http://download.oracle.com/otn/java/jdk/6u26-b03//jdk-6u26-linux-x64.bin
          FATAL: command execution failed
          java.io.IOException: GET https://edelivery.oracle.com/otn/java/jdk/6u26-b03//jdk-6u26-linux-x64.bin failed
          at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:130)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponseFromWebConnection(WebClient.java:1456)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponse(WebClient.java:1387)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponseFromWebConnection(WebClient.java:1513)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponse(WebClient.java:1387)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponseFromWebConnection(WebClient.java:1513)
          at com.gargoylesoftware.htmlunit.WebClient.loadWebResponse(WebClient.java:1387)
          at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:328)
          at com.gargoylesoftware.htmlunit.WebClient.getPage(WebClient.java:389)
          at hudson.tools.JDKInstaller.locate(JDKInstaller.java:369)
          at hudson.tools.JDKInstaller.performInstallation(JDKInstaller.java:125)
          at hudson.tools.InstallerTranslator.getToolHome(InstallerTranslator.java:61)
          at hudson.tools.ToolLocationNodeProperty.getToolHome(ToolLocationNodeProperty.java:107)
          at hudson.tools.ToolInstallation.translateFor(ToolInstallation.java:150)
          at hudson.model.JDK.forNode(JDK.java:112)
          at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:821)
          at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:75)
          at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:58)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
          at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:693)
          at hudson.model.Build$RunnerImpl.build(Build.java:178)
          at hudson.model.Build$RunnerImpl.doRun(Build.java:139)
          at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:459)
          at hudson.model.Run.run(Run.java:1389)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
          at hudson.model.ResourceController.execute(ResourceController.java:88)
          at hudson.model.Executor.run(Executor.java:230)
          Caused by: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
          at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Alerts.java:190)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1611)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1574)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1557)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.handleException(SSLSocketImpl.java:1483)
          at com.sun.net.ssl.internal.ssl.AppOutputStream.write(AppOutputStream.java:64)
          at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
          at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
          at org.apache.commons.httpclient.HttpConnection.flushRequestOutputStream(HttpConnection.java:828)
          at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.flushRequestOutputStream(MultiThreadedHttpConnectionManager.java:1565)
          at org.apache.commons.httpclient.HttpMethodBase.writeRequest(HttpMethodBase.java:2116)
          at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1096)
          at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
          at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
          at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
          at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
          at com.gargoylesoftware.htmlunit.HttpWebConnection.getResponse(HttpWebConnection.java:101)
          ... 26 more
          Caused by: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
          at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:59)
          at sun.security.validator.Validator.getInstance(Validator.java:161)
          at com.sun.net.ssl.internal.ssl.X509TrustManagerImpl.getValidator(X509TrustManagerImpl.java:108)
          at com.sun.net.ssl.internal.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:204)
          at com.sun.net.ssl.internal.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:249)
          at com.sun.net.ssl.internal.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1014)
          at com.sun.net.ssl.internal.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:124)
          at com.sun.net.ssl.internal.ssl.Handshaker.processLoop(Handshaker.java:516)
          at com.sun.net.ssl.internal.ssl.Handshaker.process_record(Handshaker.java:454)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:884)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1112)
          at com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:623)
          at com.sun.net.ssl.internal.ssl.AppOutputStream.write(AppOutputStream.java:59)
          ... 37 more
          Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty
          at java.security.cert.PKIXParameters.setTrustAnchors(PKIXParameters.java:183)
          at java.security.cert.PKIXParameters.<init>(PKIXParameters.java:103)
          at java.security.cert.PKIXBuilderParameters.<init>(PKIXBuilderParameters.java:87)
          at sun.security.validator.PKIXValidator.<init>(PKIXValidator.java:57)
          ... 49 more
          Build step 'Execute shell' marked build as failure
          Finished: FAILURE

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Andrew Bradley
          Path:
          changelog.html
          core/src/main/java/hudson/tools/JDKInstaller.java
          http://jenkins-ci.org/commit/jenkins/fa00cd25296af0b1958be8d55a787a585b18e3e0
          Log:
          [FIXED JENKINS-10634] JDK downloader now uses Jenkins proxy settings

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Kohsuke Kawaguchi
          Path:
          core/src/main/java/hudson/tools/JDKInstaller.java
          http://jenkins-ci.org/commit/jenkins/50dd2f26bced3bc22e09ec39c31ebfacb6627134
          Log:
          [FIXED JENKINS-10634] JDK downloader now uses Jenkins proxy settings

          Cherry-picked-from: fa00cd25296af0b1958be8d55a787a585b18e3e0


            People

            • Assignee:
              Unassigned
              Reporter:
              maperl maperl
            • Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: