Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10715

Finishing with a Null Pointer Exception after a successful build.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Tomcat 7.020, Windows 7, Jenkins 1.426, Perforce SCM, using the Perforce plug in.
    • Similar Issues:

      Description

      Each build is successful, but at the end of the build, the following is reported.
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] cciAdapter ........................................ SUCCESS [0.577s]
      [INFO] cciAdapter-core ................................... SUCCESS [2.655s]
      [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s]
      [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s]
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESS
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 6.257s
      [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011
      [INFO] Final Memory: 19M/123M
      [INFO] ------------------------------------------------------------------------
      Waiting for Jenkins to finish collecting data
      channel stopped
      FATAL: null
      java.lang.NullPointerException
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448)
      at hudson.model.Run.run(Run.java:1376)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:230)

      Full log file is attached.

        Attachments

          Issue Links

            Activity

            scott_the_scot Scott Marshall created issue -
            scott_the_scot Scott Marshall made changes -
            Field Original Value New Value
            Attachment upload.txt [ 20723 ]
            Description
            Each build is successful, but at the end of the build, the following is reported.
            [INFO] ------------------------------------------------------------------------
            [INFO] Reactor Summary:
            [INFO]
            [INFO] cciAdapter ........................................ SUCCESS [0.577s]
            [INFO] cciAdapter-core ................................... SUCCESS [2.655s]
            [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s]
            [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s]
            [INFO] ------------------------------------------------------------------------
            [INFO] BUILD SUCCESS
            [INFO] ------------------------------------------------------------------------
            [INFO] Total time: 6.257s
            [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011
            [INFO] Final Memory: 19M/123M
            [INFO] ------------------------------------------------------------------------
            Waiting for Jenkins to finish collecting data
            channel stopped
            FATAL: null
            java.lang.NullPointerException
            at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448)
            at hudson.model.Run.run(Run.java:1376)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:230)

            Full log file is attached.
            Each build is successful, but at the end of the build, the following is reported.
            [INFO] ------------------------------------------------------------------------
            [INFO] Reactor Summary:
            [INFO]
            [INFO] cciAdapter ........................................ SUCCESS [0.577s]
            [INFO] cciAdapter-core ................................... SUCCESS [2.655s]
            [INFO] cciAdapter-ftp .................................... SUCCESS [1.092s]
            [INFO] cciAdapter-ws Spring-WS Application ............... SUCCESS [0.996s]
            [INFO] ------------------------------------------------------------------------
            [INFO] BUILD SUCCESS
            [INFO] ------------------------------------------------------------------------
            [INFO] Total time: 6.257s
            [INFO] Finished at: Tue Aug 16 14:11:50 BST 2011
            [INFO] Final Memory: 19M/123M
            [INFO] ------------------------------------------------------------------------
            Waiting for Jenkins to finish collecting data
            channel stopped
            FATAL: null
            java.lang.NullPointerException
            at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448)
            at hudson.model.Run.run(Run.java:1376)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
            at hudson.model.ResourceController.execute(ResourceController.java:88)
            at hudson.model.Executor.run(Executor.java:230)

            Full log file is attached.
            kutzi kutzi made changes -
            Assignee kutzi [ kutzi ]
            kutzi kutzi added a comment -

            I had already fixed this in in https://github.com/jenkinsci/jenkins/commit/e7f17b5db283af591faf71aeb5f76af6626757cc
            If I had known that the NPE was already part of the 1.426 RC, I would have escalated the fix

            kutzi kutzi made changes -
            Priority Major [ 3 ] Critical [ 2 ]
            kutzi kutzi made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            scott_the_scot Scott Marshall added a comment -

            Thanks for the quick review. If I'm reading this correctly, then this will be fixed in the next release ?

            kutzi kutzi added a comment -

            Yes

            sogabe sogabe made changes -
            Link This issue is duplicated by JENKINS-10741 [ JENKINS-10741 ]
            krystian_nowak Krystian Nowak added a comment -

            This seems to be a blocker, at least for me, because since the upgrade to the latest version of Jenkins (Jenkins ver. 1.426) all my Maven-based builds fail! Env. Jenkins stand-alone, Linux Debian and Linux Ubuntu (both of them), Jenkins 1.426, one uses simply SVN, other GIT (so doesn't seem to be connected at all) - summing up, environment doesn't matter, builds just report failing in 1.426

            krystian_nowak Krystian Nowak made changes -
            Priority Critical [ 2 ] Blocker [ 1 ]
            krystian_nowak Krystian Nowak added a comment -

            @kutzi - so I assume in your answer to Scott that we should wait till 1.427 and upgrade to it when available to get the fix, right?

            kutzi kutzi added a comment -

            Yes, I'm not aware of any other workaround, but I've not actively searched for one, either.

            krystian_nowak Krystian Nowak made changes -
            Link This issue is related to JENKINS-8436 [ JENKINS-8436 ]
            krystian_nowak Krystian Nowak added a comment -

            OK, so now only big smile to Kohsuke to get a new (1.427) release rather sooner than later I guess...

            oldelvet Richard Mortimer added a comment -

            One workaround/fix is to take maven-plugin.hpi from a recent Jenkins-on-Jenkins build. I'm actually running my own build of maven-plugin.hpi based off of commit 5c7184d3cdccde44eaf8d73a38151a1c6ee5f9a9 for the past 24 hours with no ill effects.

            That should be the same as the build done at
            http://ci.jenkins-ci.org/view/Jenkins%20core/job/jenkins_main_trunk/1056/

            The appropriate plugin would be
            http://ci.jenkins-ci.org/view/Jenkins%20core/job/jenkins_main_trunk/1056/artifact/maven-plugin/target/maven-plugin.hpi

            Of course you will have to remember to unpin that version when you get the official 1.427 build.

            YMMV but it is one option available.

            kohsuke Kohsuke Kawaguchi added a comment -

            Releasing now. Sorry for a delay in noticing the issue.

            I need to also understand how come our tests missed this...

            diwakergupta Diwaker Gupta added a comment -

            I'm still seeing this error with 1.427 running on Ubuntu 10.04. This is a blocker since we use Jenkins with the Gerrit Trigger plugin which results in all our jobs being marked as failed even though the build finishes successfully.

            rec Richard Eckart de Castilho added a comment -

            I got this issue after upgrading to the Jenkins CI 1.427 and Maven 2 Plugin 1.426 (which was the one offered to me by the Update Center). I solved it by downgrading to the previously installed version of the Maven 2 plugin. When you refer to 1.427, are you talking about the M2 plugin or about Jenkins?

            oldelvet Richard Mortimer added a comment -

            It looks like Maven 2 Plugin 1.427 has not been released via the update centre. However I just upgraded my jenkins to 1.427 and confirmed that 1.427 is bundled in with that. You should be able to force jenkins to use that by going to "Manage Jenkins" -> "Manage Plugins" -> "Installed" and untick "pinned" for the Maven 2 Plugin. Then when you restart jenkins it will use the plugin bundled with Jenkins.

            krystian_nowak Krystian Nowak added a comment -

            Thanks Kohsuke for fast response!

            Cheers,
            Krystian

            ircbot Jenkins IRC Bot made changes -
            Component/s maven-plugin [ 16033 ]
            Component/s maven2 [ 15487 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 140917 ] JNJira + In-Review [ 189329 ]

              People

              • Assignee:
                kutzi kutzi
                Reporter:
                scott_the_scot Scott Marshall
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: