Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10755

NPE after successful project build with maven

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Maven 2.2.1, jenkins 1.426, debian

      Description

      After successful project build I get NPE, turning on and off various build options does not affect result.
      Downgrade to 1.425 has solved the issue.
      It happened after Jenkins has been automatically upgraded, not all projects were affected, in my case 2 projects were.
      Stack trace:

      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1 minute 25 seconds
      [INFO] Finished at: Thu Aug 18 13:47:36 CEST 2011
      [INFO] Final Memory: 101M/1093M
      [INFO] ------------------------------------------------------------------------
      [FINDBUGS] Aggregating results of warehouse-udf-parent
      [FINDBUGS] Using set difference to compute new warnings
      [FINDBUGS] Not changing build status, since no threshold has been exceeded
      [FINDBUGS] Aggregating results of warehouse-udf-core
      [FINDBUGS] Using set difference to compute new warnings
      [FINDBUGS] Not changing build status, since no threshold has been exceeded
      [FINDBUGS] Aggregating results of warehouse-udf-pig
      [FINDBUGS] Using set difference to compute new warnings
      [FINDBUGS] Not changing build status, since no threshold has been exceeded
      [FINDBUGS] Aggregating results of warehouse-udf-hive
      [FINDBUGS] Using set difference to compute new warnings
      [FINDBUGS] Not changing build status, since no threshold has been exceeded
      [TASKS] Aggregating results of warehouse-udf-parent
      [TASKS] Using set difference to compute new warnings
      [TASKS] Not changing build status, since no threshold has been exceeded
      [TASKS] Aggregating results of warehouse-udf-core
      [TASKS] Using set difference to compute new warnings
      [TASKS] Not changing build status, since no threshold has been exceeded
      [TASKS] Aggregating results of warehouse-udf-pig
      [TASKS] Using set difference to compute new warnings
      [TASKS] Not changing build status, since no threshold has been exceeded
      [TASKS] Aggregating results of warehouse-udf-hive
      [TASKS] Using set difference to compute new warnings
      [TASKS] Not changing build status, since no threshold has been exceeded
      channel stopped
      FATAL: null
      java.lang.NullPointerException
      	at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:833)
      	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:448)
      	at hudson.model.Run.run(Run.java:1376)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:479)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:230)
      
      

        Issue Links

          Activity

          oldelvet Richard Mortimer added a comment -

          Duplicate of JENKINS-10715.


            People

            • Assignee:
              Unassigned
              Reporter:
              wlk Wojciech Langiewicz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: