Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10762

Misleading error when upstream jobs do not archive the artifacts

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: copyartifact-plugin
    • Labels:
      None
    • Environment:
      Tested Jenkins Versions:
      Jenkins ver. 1.409.1
      Jenkins ver. 1.425 / 1.426
    • Similar Issues:

      Description

      The copyartifacts plugin looks in the archive directory of the referenced project. If this does not exist because the job did not have "Archive the artifacts" selected, the reported error does not indicate this. The error as emitted is:

      Started by user anonymous
      Unable to access workspace for artifact copy. Slave node offline?
      Build step 'Copy artifacts from another project' marked build as failure
      Finished: FAILURE

      Only after attaching a debugger did we discover the full path that the plugin was using for the workspace and realized we needed to enable artifact archiving.

        Attachments

          Issue Links

            Activity

            mantis John Wildman added a comment -

            At the very least the docs should say this is a requirement, but it would be nice if the plugin detected this missing from the upstream job and displayed a better message.

            mantis John Wildman added a comment -

            JENKINS-10758 was the original defect but through further investigation the root cause was found. JENKINS-10758 will be closed.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: alanharder
            Path:
            src/main/java/hudson/plugins/copyartifact/CopyArtifact.java
            src/main/resources/hudson/plugins/copyartifact/Messages.properties
            http://jenkins-ci.org/commit/copyartifact-plugin/cdf887fecefde3ddee5a5bd0a5eaf1de641401a7
            Log:
            [FIXED JENKINS-10762] improve error message if source dir cannot be accessed

            dogfood dogfood added a comment -

            Integrated in plugins_copyartifact #58
            [FIXED JENKINS-10762] improve error message if source dir cannot be accessed

            alanharder : cdf887fecefde3ddee5a5bd0a5eaf1de641401a7
            Files :

            • src/main/java/hudson/plugins/copyartifact/CopyArtifact.java
            • src/main/resources/hudson/plugins/copyartifact/Messages.properties

              People

              • Assignee:
                mindless Alan Harder
                Reporter:
                mantis John Wildman
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: