Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10859

hudson.util.IOException2: remote file operation failed: D:\JenkinsSlave\workspace\DemoFreeStyle at hudson.remoting.Channel@27d827d8:dswinbld301-Flex-Win

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      AIX master running under WAS 6. Windows server 2003 slave
    • Similar Issues:

      Description

      The master slave connection seems to be intermittent. The slave is able to connect to the master but for some onknown reason builds will start to fail and the error is always hudson.util.IOException2: remote file operation failed: D:\JenkinsSlave\workspace\DemoFreeStyle at hudson.remoting.Channel@27d827d8:dswinbld301-Flex-Win.

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            No response from the reporter, closing as a duplicate of JENKINS-10771 as Baptiste Mathus suggested 5 years ago.

            eltoru Tobias Rundgren added a comment -

            We had similar problem with our build slaves when use :Launche slave agents on unix machines via ssh

            We solved it by use of : Launch slave via execution of command on Master

            Launche command:
            ssh -o "LogLevel=ERROR" -o "BatchMode=yes" -o "StrictHostKeyChecking=no" -o "UserKnownHostsFile=/dev/null" -i /home/jenkinsuser/.ssh/jenkinsuser.rsa jenkinsuser@buildslave-hostname "java -jar $jenkinshome/.hudson/war/WEB-INF/slave.jar"

            Now slaves are running stable again.

            batmat Baptiste Mathus added a comment -

            I think this issue is more than related to JENKINS-10771. It's duplicate.

            Bruce, could you try and paste a complete stack trace to check it's the same or a different issue.

            khaido Khai Do added a comment - - edited

            I think this is a generic problem, not exactly same as JENKINS-10905. I have the same problem, my jenkins install will work for a few builds then it will continually fail on svn checkout with this exact same failure. It's really bad because once this failure occurs all of my slaves will have the same failure. Yes, I did make sure that the slaves and master are the same version. My Env is jenkins master (ver 1.409.2) on CentOS 5.6 running in a tomcat 6 container. I have 4 slaves: CetnOS (SSH), Win XP (Win Service), Win 7 (JNLP), and Ubuntu (SSH). I get this failure on all of my slaves and the only way to get the builds working again is by restarting the master. Restarting slaves will not fix the problem.

            here's a few posting from the google group:
            http://groups.google.com/group/jenkinsci-users/browse_thread/thread/8a783e9865bcff11/e20fe877b71108ce#e20fe877b71108ce
            http://groups.google.com/group/jenkinsci-users/browse_thread/thread/b404c8ba4edf9f91/8df98229ff76a6dc?lnk=gst&q=khaido#8df98229ff76a6dc

            robsimon robsimon added a comment -
            robsimon robsimon added a comment -

            Have you checked if there are open file handles on that workspace?


              People

              • Assignee:
                Unassigned
                Reporter:
                bgrissom bruce grissom
              • Votes:
                3 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: