Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-10993

mvn deploy Broken file transfere returncode 409

    Details

    • Type: Bug
    • Status: Open
    • Priority: Critical
    • Resolution: Unresolved
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Linux 64bit / RHEL 6.0 / Maven 2.2

      Description

      I am trying to deploy some maven artifacts to artifactory via jenkins / deploy artifacts . But it seems the mvn deploy is broken in the current version.
      Something seems to be wrong with the md5 hashes.

      Errorlog Hudson:

      ERROR: Error deploying artifact: Failed to transfer file: http://artifactoryurl:8081/artifactory/libs-snapshot-local//com/bla/parent/1.0-SNAPSHOT/parent-1.0-SNAPSHOT.pom.md5. Return code is: 409

      Errorlog Artifactory:

      Sending HTTP error code 409: Checksum error for 'com/bla/parent/1.0-SNAPSHOT/parent-1.0-SNAPSHOT.pom.md5': received '43c2d52fbcf75065e13e1c1bd32b1bfc' but actual is '0141046f46d90bd108d65e4ec46d8774'.

      Version 1.427 works properly after downgrading. So it seems to be a Bug in newer versions up to 1.428.

      Can anybody confirm this bug ?

        Activity

        Hide
        banoss banoss added a comment - - edited

        Seen issue where our snapshots (being deployed by Jenkins post build) started to exhibit similar problem when downloading these snapshots.

        [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = 'f78129e7a824eeeb3c31cfe76cc37ad86af147b8'; remote = 'ca4bda12e6fde2cc68f07d71b660e2496f6901b5' - RETRYING
        [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = 'f78129e7a824eeeb3c31cfe76cc37ad86af147b8'; remote = 'ca4bda12e6fde2cc68f07d71b660e2496f6901b5' - IGNORING

        This did not seem to be affecting downloads. The only change I could attribute was upgrading Jenkins from 1.424 to 1.430. Just reverted back to 1.424 and will monitor.

        [CONFIRMED: Jenkins 1.424 does not cause this issue. Does look like the publish to repository is indeed busted.]

        Show
        banoss banoss added a comment - - edited Seen issue where our snapshots (being deployed by Jenkins post build) started to exhibit similar problem when downloading these snapshots. [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = 'f78129e7a824eeeb3c31cfe76cc37ad86af147b8'; remote = 'ca4bda12e6fde2cc68f07d71b660e2496f6901b5' - RETRYING [WARNING] *** CHECKSUM FAILED - Checksum failed on download: local = 'f78129e7a824eeeb3c31cfe76cc37ad86af147b8'; remote = 'ca4bda12e6fde2cc68f07d71b660e2496f6901b5' - IGNORING This did not seem to be affecting downloads. The only change I could attribute was upgrading Jenkins from 1.424 to 1.430. Just reverted back to 1.424 and will monitor. [CONFIRMED: Jenkins 1.424 does not cause this issue. Does look like the publish to repository is indeed busted.]
        Hide
        sisko255 sisko255 added a comment -

        Hi,

        thanks for the comment.

        Version 1.427 works for me fine too.

        Show
        sisko255 sisko255 added a comment - Hi, thanks for the comment. Version 1.427 works for me fine too.

          People

          • Assignee:
            Unassigned
            Reporter:
            sisko255 sisko255
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated: