Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11130

java.io.IOException: Unexpected termination of the channel - SEVERE: I/O error in channel Chunked connection when using jenkins-cli.jar (works on older Hudson version)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cli
    • Labels:
      None
    • Environment:
      * Running on SLES9 Linux server with 4 CPUs and plenty of diskspace.
      * Tomcat 7.0.14
      * JDK 1.6.0_14
      * Only ONE Master configuration - no slaves are configured
      * 3 Executors - (one less than the max number of CPUs)
    • Similar Issues:

      Description

      We are currently seeing the following issue using the jenkins-cli.jar
      with Jenkins 1.430. Tried going to 1.431, same issue.

      Each time we insure we have the latest matching jenkins-cli.jar using the link on the Manage Jenkins page.

      From inside a Jenkins job (I'll call it the parent) I'm trying to
      execute multiple jobs using the client jar. On the last job, I
      include the -s parameter so the parent job will not finish until the
      last job in the list is complete. The problem is that after about 15
      secs of waiting, the parent job ends (fails) with the EOF exception
      below.

      IMPORTANT INFO: When performing this exact same build using an older hudson-cli.jar with an older (pre-fork) version of Hudson v1.339, THIS WORKS. We want to move all of our builds over to the latest Jenkins version, and this is blocking us at the moment.

      We have searched all day and tried numerous things including
      reducing the number of jobs and also trying to run them sequentially.

      Stack trace seen in Console at failure:

      [workspace] $ /bin/bash -xe /opt/apache-tomcat-7.0.14_jenkins/temp/
      hudson4690948305077288103.sh
      + WAR_FOLDER=/tmp/trunk/UIToolkit1.1.2
      + rm -rf /tmp/trunk/UIToolkit1.1.2/calendar.war /tmp/trunk/
      UIToolkit1.1.2/Pay.war /tmp/trunk/UIToolkit1.1.2/OrgChart.war
      + /opt/Sun/jdk1.6.0_14/bin/java jar /opt/Sun/jdk1.6.0_14/lib/jenkins
      cli.jar s http://jenkins-host:8082/jenkins/ build XYZ_Platform
      Calendar -p SVN_PATH=trunk -p STATIC_PATH=UIToolkit1.1.2
      + /opt/Sun/jdk1.6.0_14/bin/java jar /opt/Sun/jdk1.6.0_14/lib/jenkins
      cli.jar -s http://jenkins-host:8082/jenkins/ build XYZ_Platform-Pay -p
      SVN_PATH=trunk -p STATIC_PATH=UIToolkit1.1.2
      + /opt/Sun/jdk1.6.0_14/bin/java jar /opt/Sun/jdk1.6.0_14/lib/jenkins
      cli.jar s http://jenkins-host:8082/jenkins/ build XYZ_Platform
      OrgChart -p SVN_PATH=trunk -p STATIC_PATH=UIToolkit1.1.2
      + /opt/Sun/jdk1.6.0_14/bin/java jar /opt/Sun/jdk1.6.0_14/lib/jenkins
      cli.jar s http://jenkins-host:8082/jenkins/ build XYZ_Platform
      PolicyAck -s -p SVN_PATH=trunk -p STATIC_PATH=UIToolkit1.1.2
      Sep 16, 2011 4:35:37 PM hudson.remoting.Channel$ReaderThread run
      SEVERE: I/O error in channel Chunked connection to http://jenkins-host:8082/jenkins/cli
      java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:1093)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream
      $BlockDataInputStream.peekByte(ObjectInputStream.java:2498)
      at
      java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1273)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:
      348)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:1087)
      Exception in thread "main" hudson.remoting.RequestAbortedException:
      hudson.remoting.RequestAbortedException: java.io.IOException:
      Unexpected termination of the channel
      at hudson.remoting.Request.call(Request.java:149)
      at hudson.remoting.Channel.call(Channel.java:681)
      at
      hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java­:
      158)
      at $Proxy2.main(Unknown Source)
      at hudson.cli.CLI.execute(CLI.java:171)
      at hudson.cli.CLI._main(CLI.java:297)
      at hudson.cli.CLI.main(CLI.java:216)
      Caused by: hudson.remoting.RequestAbortedException:
      java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.Request.abort(Request.java:273)
      at hudson.remoting.Channel.terminate(Channel.java:732)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:1117)
      Caused by: java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:1093)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream
      $BlockDataInputStream.peekByte(ObjectInputStream.java:2498)
      at
      java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1273)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:
      348)
      at hudson.remoting.Channel$ReaderThread.run(Channel.java:1087)
      Build step 'Execute shell' marked build as failure
      Notifying upstream projects of job completion
      Finished: FAILURE

        Attachments

          Activity

          oldelvet Richard Mortimer added a comment -

          One workaround is to set the Tomcat Connector connectionUploadTimeout and disableUploadTimeout attributes in the Tomcat server.xml file. Setting it to 60 seconds allows the existing ping at 30 seconds duration to work properly.

              <Connector port="8080" protocol="HTTP/1.1"
                         connectionTimeout="20000" 
                         disableUploadTimeout="false"
                         connectionUploadTimeout="60000"
                         URIEncoding="UTF-8"
                         redirectPort="8443" />
          
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Richard Mortimer
          Path:
          changelog.html
          cli/src/main/java/hudson/cli/CLI.java
          http://jenkins-ci.org/commit/jenkins/92496f99e4c941de9d7dab628466cadcde70d808
          Log:
          [FIXED JENKINS-11130] SEVERE: I/O error in channel Chunked connection when using jenkins-cli.jar

          When using HTTP full duplex connections the upstream channel can be idle for
          long periods of time and the webserver will time the connection out. Jenkins
          sees this and terminates the downstream channel causing the unexpected closure
          of the read channel in the CLI client.

          Timeout of 15 seconds is based on the 20 second default timeout as seen in
          Ubuntu Oneiric Tomcat 6 installations.

          Compare: https://github.com/jenkinsci/jenkins/compare/9730359...92496f9

          dogfood dogfood added a comment -

          Integrated in jenkins_main_trunk #1271
          [FIXED JENKINS-11130] SEVERE: I/O error in channel Chunked connection when using jenkins-cli.jar

          Kohsuke Kawaguchi : 92496f99e4c941de9d7dab628466cadcde70d808
          Files :

          • changelog.html
          • cli/src/main/java/hudson/cli/CLI.java
          mcs13099 mark streit added a comment -

          We have downloaded and installed the LATEST 1.441 release that lists the fix for this problem. Currently we were running 1.438 on Winstone only (since with Tomcat 6 or 7, we had experienced the error HOWEVER yet under Winstone, it worked OK so that was our workaround - while running 1.438).

          Now with Jenkins 1.441 - we are getting the ERROR again and NOW WITH BOTH Winstone and the Tomcat configurations). We have left the Jenkins 1.441 WAR file in place running on Winstone, and reverted the CLI jar file back to the 1.438 version for now and that appears to work again with Winstone.

          Checked Manifest of CLI jar downloaded with the 1.441 WAR installation:

          Manifest-Version: 1.0
          Archiver-Version: Plexus Archiver
          Created-By: Apache Maven
          Built-By: kohsuke
          Build-Jdk: 1.6.0_26
          Main-Class: hudson.cli.CLI
          Jenkins-CLI-Version: 1.441

          Under Tomcat 7, we get this stacktrace:

          Started by command line
          [workspace] $ /bin/bash -xe /opt/apache-tomcat-7.0.22_jenkins/temp/hudson32817888834817830.sh
          + /opt/Sun/jdk1.6.0_14/bin/java -jar /opt/Sun/jdk1.6.0_14/lib/jenkins-cli.jar -s http://11.22.33.44:8082/jenkins/ build XYZ_Project-SharedLibs -s -p SVN_PATH=trunk
          Dec 5, 2011 12:59:11 PM hudson.remoting.Channel$ReaderThread run
          SEVERE: I/O error in channel Chunked connection to http://11.22.33.44:8082/jenkins/cli
          java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1115)
          Caused by: java.io.EOFException
          at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2554)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1297)
          at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1109)
          Exception in thread "main" hudson.remoting.RequestAbortedException: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.Request.call(Request.java:149)
          at hudson.remoting.Channel.call(Channel.java:681)
          at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:158)
          at $Proxy2.main(Unknown Source)
          at hudson.cli.CLI.execute(CLI.java:200)
          at hudson.cli.CLI._main(CLI.java:330)
          at hudson.cli.CLI.main(CLI.java:245)
          Caused by: hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.Request.abort(Request.java:273)
          at hudson.remoting.Channel.terminate(Channel.java:732)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1139)
          Caused by: java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1115)
          Caused by: java.io.EOFException
          at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2554)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1297)
          at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1109)
          Build step 'Execute shell' marked build as failure
          Notifying upstream projects of job completion
          Finished: FAILURE

          Under Winstone, we get this stacktrace - it's somewhat different:

          Started by command line
          [workspace] $ /bin/bash -xe /tmp/hudson10791816374444704.sh
          + /opt/Sun/jdk1.6.0_14/bin/java -jar /opt/Sun/jdk1.6.0_14/lib/jenkins-cli.jar -s http://11.22.33.44:8082/jenkins/ build XYZ_Project-SharedLibs -s -p SVN_PATH=trunk
          Dec 5, 2011 1:18:22 PM hudson.remoting.Channel$ReaderThread run
          SEVERE: I/O error in channel Chunked connection to http://11.22.33.44:8082/jenkins/cli
          java.io.IOException: Premature EOF
          at sun.net.www.http.ChunkedInputStream.readAheadBlocking(ChunkedInputStream.java:538) (http://www.http.ChunkedInputStream.readAheadBlocking%28ChunkedInputStream.java:538%29)
          at sun.net.www.http.ChunkedInputStream.readAhead(ChunkedInputStream.java:582) (http://www.http.ChunkedInputStream.readAhead%28ChunkedInputStream.java:582%29)
          at sun.net.www.http.ChunkedInputStream.read(ChunkedInputStream.java:669) (http://www.http.ChunkedInputStream.read%28ChunkedInputStream.java:669%29)
          at java.io.FilterInputStream.read(FilterInputStream.java:116)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2504) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2504%29)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2499) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2499%29)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2488) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2488%29)
          at java.io.ObjectInputStream$PeekInputStream.peek(ObjectInputStream.java:2249)
          at java.io.ObjectInputStream$BlockDataInputStream.peek(ObjectInputStream.java:2542)
          at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2552)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1297)
          at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1109)
          Exception in thread "main" hudson.remoting.RequestAbortedException: hudson.remoting.RequestAbortedException: java.io.IOException: Premature EOF
          at hudson.remoting.Request.call(Request.java:149)
          at hudson.remoting.Channel.call(Channel.java:681)
          at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:158)
          at $Proxy2.main(Unknown Source)
          at hudson.cli.CLI.execute(CLI.java:200)
          at hudson.cli.CLI._main(CLI.java:330)
          at hudson.cli.CLI.main(CLI.java:245)
          Caused by: hudson.remoting.RequestAbortedException: java.io.IOException: Premature EOF
          at hudson.remoting.Request.abort(Request.java:273)
          at hudson.remoting.Channel.terminate(Channel.java:732)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1139)
          Caused by: java.io.IOException: Premature EOF
          at sun.net.www.http.ChunkedInputStream.readAheadBlocking(ChunkedInputStream.java:538) (http://www.http.ChunkedInputStream.readAheadBlocking%28ChunkedInputStream.java:538%29)
          at sun.net.www.http.ChunkedInputStream.readAhead(ChunkedInputStream.java:582) (http://www.http.ChunkedInputStream.readAhead%28ChunkedInputStream.java:582%29)
          at sun.net.www.http.ChunkedInputStream.read(ChunkedInputStream.java:669) (http://www.http.ChunkedInputStream.read%28ChunkedInputStream.java:669%29)
          at java.io.FilterInputStream.read(FilterInputStream.java:116)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2504) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2504%29)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2499) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2499%29)
          at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:2488) (http://www.protocol.http.HttpURLConnection$HttpInputStream.read%28HttpURLConnection.java:2488%29)
          at java.io.ObjectInputStream$PeekInputStream.peek(ObjectInputStream.java:2249)
          at java.io.ObjectInputStream$BlockDataInputStream.peek(ObjectInputStream.java:2542)
          at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2552)
          at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1297)
          at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
          at hudson.remoting.Channel$ReaderThread.run(Channel.java:1109)
          Build step 'Execute shell' marked build as failure
          Notifying upstream projects of job completion
          Finished: FAILURE


            People

            • Assignee:
              oldelvet Richard Mortimer
              Reporter:
              mcs13099 mark streit
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: