Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11284

Permission denied .bzr.log

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: bazaar-plugin
    • Labels:
      None
    • Environment:
      Jenkins Bazaar plugin 1.16; Ubuntu 11.10 package for Jenkins.
    • Similar Issues:

      Description

      I have job that first tries to check out the flufl.enum trunk code from Launchpad. You can see the url below. When I look at /var/lib/jenkins/job/taster/workspace, everything seems okay. In fact, there's a .bzr directory that's 0755 and jenkins:jenkins, plus it has the expected contents of the branch. I don't know why it's getting the permission denied, but this does seem to break my job.

      Started by user anonymous
      Cleaning workspace...
      $ bzr branch https+urllib://code.launchpad.net/~barry/flufl.enum/trunk/ /var/lib/jenkins/jobs/taster/workspace
      Branched 58 revision(s).
      Getting local revision...
      $ bzr revision-info -d /var/lib/jenkins/jobs/taster/workspace
      info result: bzr revision-info -d /var/lib/jenkins/jobs/taster/workspace returned 0. Command output: "58 barry@python.org-20111007230411-32m796uwavv82q0r
      " stderr: "failed to open trace file: [Errno 13] Permission denied: '.bzr.log'
      "
      RevisionState revno:58 revid:barry@python.org-20111007230411-32m796uwavv82q0r

        Attachments

          Activity

          zigarn Alexandre Garnier added a comment -

          .bzr.log file is the log file for bzr and is not in .bzr folder.
          Is location can be set through the anv var BZR_LOG (Environment Variables)

          It's default location is in ~/.bzr.log. You can check the current location by running bzr version (Configuration Settings)

          So check the current location and your rights on it and modify the permissions or the BZR_LOG env var to set an other location.

          stewart Stewart Smith added a comment -

          I can't reproduce this, it's likely a local permissions problem. Perhaps you need to chmod some files or use workaround described here.


            People

            • Assignee:
              sdirector Monty Taylor
              Reporter:
              barry Barry Warsaw
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: