Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: plugin-proposals
    • Labels:
      None
    • Environment:
      Red hat linux
    • Similar Issues:

      Description

      We are using Jenkins in Red hat Linux domain.
      I have installed monitoring plugin in my Jenkins 1.411 version.

      After installed, i couldn't able to find it.
      I have restarted 3 times and checked in Manage jenkins at the bottom.
      but it is not available.

      but when i check in to Server,
      hpi file is available. i have restarted three times. but still i
      couldn't able to find it "Monitoring plugin"

      Pls check and advice me on this regard.

        Attachments

          Activity

          evernat evernat added a comment -

          What is the size of the downloaded monitoring.hpi file on the server?
          Is it a valid zip file? (can you open it with a zip manager?)
          Do you have a stack-trace about this plugin in the server logs?

          If needed, you can download the hpi file manually from http://mirrors.jenkins-ci.org/plugins/monitoring/

          suresh1256644 Suresh Kumar added a comment -

          Hi,

          i have downloaded monitoring.hpi once again manually from link which you have sent. The size of hpi file is 2708426. i could able to open hpi file with Zip manager. herewith i have attached log file also. please check and help to me for get this plug in installed.

          suresh1256644 Suresh Kumar added a comment -

          Still i am unable to find the monitoring plugin in my Hudson. i have restarted 3 times.

          evernat evernat added a comment - - edited

          The log file added in the issue says: NoClassDefFoundError: org.slf4j.ILoggerFactory for the monitoring plugin. The cause is that your IBM J9 JVM has a different, and so questionable, class loading behavior than other JVMs.

          Anyway, it is a bug and it is now fixed in the monitoring plugin.
          I have added the dependency slf4j-api in the plugin. (rev 40073 of https://svn.jenkins-ci.org/trunk/hudson/plugins/monitoring/pom.xml)
          If you want to use the monitoring plugin in the IBM J9 JVM, I have made a new build from the trunk, which is the same as v1.32.1 + the fix.
          The new build is available at http://javamelody.googlecode.com/files/monitoring.hpi so you can submit it in the Jenkins plugin manager or you can copy it to the server.

          And the fix will be available in the next release (1.33, in a few weeks).

          Thanks

          dennisl Dennis Lundberg added a comment -

          Hi

          We stumbled on this bug as well today.
          After downloading the patched build, the plugin starts OK.


            People

            • Assignee:
              evernat evernat
              Reporter:
              suresh1256644 Suresh Kumar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: