Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11318

Wagon 2.0 upgrade broke the Redeploy task for webdav repositories

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Similar Issues:
      Show 5 results

      Description

      Problem of wagon compatibility between Aether/Wagon 2 in Jenkins 1.434

      Uploading: http://repository.exoplatform.org/content/repositories/exo-private-snapshots/com/exoplatform/platform/cloud/exo.platform.cloud/3.5.0-CR1-SNAPSHOT/exo.platform.cloud-3.5.0-CR1-20111012.034911-9.pom
      FATAL: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
      java.lang.NoSuchMethodError: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
      	at org.apache.maven.wagon.providers.webdav.WebDavWagon.doMkCol(WebDavWagon.java:157)
      	at org.apache.maven.wagon.providers.webdav.WebDavWagon.mkdirs(WebDavWagon.java:129)
      	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:512)
      	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:476)
      	at org.apache.maven.wagon.providers.webdav.WebDavWagon.put(WebDavWagon.java:332)
      	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$PutTask.run(WagonRepositoryConnector.java:825)
      	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.put(WagonRepositoryConnector.java:465)
      	at org.sonatype.aether.impl.internal.DefaultDeployer.deploy(DefaultDeployer.java:278)
      	at org.sonatype.aether.impl.internal.DefaultDeployer.deploy(DefaultDeployer.java:215)
      	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.deploy(DefaultRepositorySystem.java:480)
      	at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:137)
      	at hudson.maven.reporters.MavenArtifactRecord.deploy(MavenArtifactRecord.java:189)
      	at hudson.maven.RedeployPublisher.perform(RedeployPublisher.java:158)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:694)
      	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:669)
      	at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:987)
      	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:616)
      	at hudson.model.Run.run(Run.java:1429)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:478)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:230)
      

        Attachments

          Issue Links

            Activity

            aheritier Arnaud Héritier added a comment -

            Note : as you can see in logs it is deploying using webdav protocol
            For now I'm downgrading my production server and will do more tests

            olamy olamy added a comment -

            uhm not sure the old commons-httpclient is correctly locked in maven-plugin pom.

            aheritier Arnaud Héritier added a comment -

            3.1 is defined in parent pom and should be used in maven-plugin
            Is it enough ?

            olamy olamy added a comment -

            yup that the good version
            I wonder if we have somewhere a duplicated forked class org/apache/commons/httpclient/HttpMethod

            aheritier Arnaud Héritier added a comment -

            ok I find in Wagon 2.0 that it uses :

                  <dependency>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpclient</artifactId>
                    <version>4.1.2</version>
                  </dependency>
                  <dependency>
                    <groupId>org.apache.httpcomponents</groupId>
                    <artifactId>httpcore</artifactId>
                    <version>4.1.2</version>
                  </dependency>
            

            Let's give it a try...

            olamy olamy added a comment -

            AFAIK WebDavWagon use webdav jackrabbit 2.2.5 which use commons-httpclient 3.1
            see: http://repo1.maven.org/maven2/org/apache/maven/wagon/wagon-webdav-jackrabbit/2.0/wagon-webdav-jackrabbit-2.0.pom

            org.apache.httpcomponents: httpclient:4.1.2 is used by wagon-http.
            IMHO the problem is not here but a class loader issue with something which load an old version of the class org/apache/commons/httpclient/HttpMethod

            bcygan bcygan added a comment -

            We are affected as well, identical stack trace.

            olamy olamy added a comment -

            probably linked to http://jira.codehaus.org/browse/WAGON-359
            a workaround can be to use the shaded version of wagon http client in the maven plugin

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: olivier lamy
            Path:
            maven-plugin/pom.xml
            http://jenkins-ci.org/commit/jenkins/9eaf921ed6b5bfb45136b608751044d6bbd0146f
            Log:
            [FIXED JENKINS-11318] Wagon 2.0 upgrade broke the Redeploy task for webdav repositories
            upgrade embeder version which doesn't have more deps on wagon http ligth

            Compare: https://github.com/jenkinsci/jenkins/compare/b29f3de...9eaf921

            olamy olamy added a comment -

            if you guys could test a build of master that would be perfect

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1326
            [FIXED JENKINS-11318] Wagon 2.0 upgrade broke the Redeploy task for webdav repositories

            Olivier Lamy : 9eaf921ed6b5bfb45136b608751044d6bbd0146f
            Files :

            • maven-plugin/pom.xml
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Olivier Lamy
            Path:
            changelog.html
            http://jenkins-ci.org/commit/jenkins/9140a2bf9c54ebaa257ecab70d043a5f39ec69f8
            Log:
            change log entry for JENKINS-11318

            aheritier Arnaud Héritier added a comment -

            My current tests on 1.443-SNAPSHOT are confirming that it is fixed. I'll do more test in incoming hours

            blitzba Bernd Litzba added a comment -

            Just did an update from version 1.442 to 1.444 and got the same problem again:

            FATAL: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
            java.lang.NoSuchMethodError: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
            at org.apache.maven.wagon.providers.webdav.WebDavWagon.doMkCol(WebDavWagon.java:157)
            at org.apache.maven.wagon.providers.webdav.WebDavWagon.mkdirs(WebDavWagon.java:129)

            nagor Michal Nagorski added a comment -

            Hi All.

            The same problem applies on version 1.443. Do you know any workaround for this issue?

            aheritier Arnaud Héritier added a comment -

            Strange I don't have anymore this issue with 1.443
            What is your maven version ? Your deployment URL ? The wagon extension declared in your POM to upload with webdav ?

            nagor Michal Nagorski added a comment - - edited

            Hi,

            configuration of job is:

            Repo URL: dav:http://host1.xxxxx.com:8081/nexus/content/repositories/snapshots/
            Repo ID: nexus
            

            In Jenkins setttings.xml I have configured server:

            <servers>
            	<server>
            		<id>nexus</id>
            		<username>admin</username>
            		<password>xxxxxxx</password>
            	</server>	
            </servers>
            

            Maven version is 3.0.3.

            This same configuration was working with Hudson.

            Stack trace:

            Uploading: http://host1.xxxxx.com:8081/nexus/content/repositories/snapshots/com/xxxxxx/project1-4.0-20111220.144029-95.pom
            FATAL: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
            java.lang.NoSuchMethodError: org.apache.maven.wagon.providers.webdav.WebDavWagon.execute(Lorg/apache/commons/httpclient/HttpMethod;)I
            	at org.apache.maven.wagon.providers.webdav.WebDavWagon.doMkCol(WebDavWagon.java:157)
            	at org.apache.maven.wagon.providers.webdav.WebDavWagon.mkdirs(WebDavWagon.java:129)
            	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:517)
            	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:495)
            	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:475)
            	at org.apache.maven.wagon.providers.webdav.WebDavWagon.put(WebDavWagon.java:332)
            	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector$PutTask.run(WagonRepositoryConnector.java:811)
            	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.put(WagonRepositoryConnector.java:467)
            	at org.sonatype.aether.impl.internal.DefaultDeployer.deploy(DefaultDeployer.java:274)
            	at org.sonatype.aether.impl.internal.DefaultDeployer.deploy(DefaultDeployer.java:211)
            	at org.sonatype.aether.impl.internal.DefaultRepositorySystem.deploy(DefaultRepositorySystem.java:443)
            	at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:137)
            	at hudson.maven.reporters.MavenArtifactRecord.deploy(MavenArtifactRecord.java:182)
            	at hudson.maven.RedeployPublisher.perform(RedeployPublisher.java:158)
            	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
            	at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:692)
            	at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:667)
            	at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:1014)
            	at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:614)
            	at hudson.model.Run.run(Run.java:1429)
            	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:481)
            	at hudson.model.ResourceController.execute(ResourceController.java:88)
            	at hudson.model.Executor.run(Executor.java:238)
            
            blitzba Bernd Litzba added a comment -

            We are using Maven 3.0.3
            And this is the wagon extension declared in the POM:
            <extension>
            <groupId>org.apache.maven.wagon</groupId>
            <artifactId>wagon-webdav-jackrabbit</artifactId>
            <version>2.1</version>
            </extension>

            olamy olamy added a comment -

            must be probably due to http://jira.codehaus.org/browse/WAGON-359.
            I will upgrade to wagon 2.2.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: olivier lamy
            Path:
            maven-plugin/pom.xml
            http://jenkins-ci.org/commit/jenkins/7bba3abcf9456e5a933e2207c4d87bc58a9f2fc0
            Log:
            JENKINS-11318 updgrade to wagon 2.2

            olamy olamy added a comment -

            fix for 1.446.

            nagor Michal Nagorski added a comment -

            Thanks for support. But when this build will be available? Currently I'm blocked by this issue.

            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #1379
            JENKINS-11318 updgrade to wagon 2.2

            Olivier Lamy : 7bba3abcf9456e5a933e2207c4d87bc58a9f2fc0
            Files :

            • maven-plugin/pom.xml
            olamy olamy added a comment -

            why this issue has been reopen ? At least provide comments on the reason.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: olivier lamy
            Path:
            maven-plugin/pom.xml
            http://jenkins-ci.org/commit/jenkins/6771142937bc6f743586b80452bc83f892ae35ae
            Log:
            JENKINS-11318 updgrade to wagon 2.2
            (cherry picked from commit 7bba3abcf9456e5a933e2207c4d87bc58a9f2fc0)

            Conflicts:

            maven-plugin/pom.xml

            Compare: https://github.com/jenkinsci/jenkins/compare/3554a4c...6771142

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: olivier lamy
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/84de2a20c937ae6460bee00ee28381b02d588831
            Log:
            [FIXED JENKINS-11318] Wagon 2.0 upgrade broke the Redeploy task for webdav repositories
            upgrade embeder version which doesn't have more deps on wagon http ligth

            Originally-Committed-As: 9eaf921ed6b5bfb45136b608751044d6bbd0146f

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: olivier lamy
            Path:
            pom.xml
            http://jenkins-ci.org/commit/maven-plugin/682693fbc1e90893c0b1cb8170e6ab6f340ce6a9
            Log:
            JENKINS-11318 updgrade to wagon 2.2

            Originally-Committed-As: 7bba3abcf9456e5a933e2207c4d87bc58a9f2fc0


              People

              • Assignee:
                olamy olamy
                Reporter:
                aheritier Arnaud Héritier
              • Votes:
                3 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: