Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11547

Jobs trigger continually even though there are no changes due to git repository being "corrupt"

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None

      Description

      There is a problem with the git polling mechanism which is causing all our jobs to kick themselves off continually. This happens at random times and just fixes itself, but is causing us all sorts of problems due to the large number of builds triggered.

      This is an example of the git polling log:

       
      Started on 28-Oct-2011 03:20:22
      Using strategy: Default
      [poll] Last Build : #480
      [poll] Last Built Revision: Revision abcb8a2492b390521e0c720f96f66a88eae09f18 (origin/master)
      Workspace has a .git repository, but it appears to be corrupt.
      No Git repository yet, an initial checkout is required
      Done. Took 0.26 sec
      Changes found
      

      This is caused when a "git rev-parse --verify HEAD" fails for some reason, but there is no logging to help in what might have gone wrong. It looks like the try/catch around the validateRevision line is too simplistic and the cause of the exception should be considered before returning false.

        Activity

        djhaskin987 Daniel Haskin added a comment -

        We have the same problem, but the git executable is flock'ed on our server, so that only one process can actually run the git at one time. The issue still persists for us, however.

        jzaun Justin Zaun added a comment -

        Hi everyone. I registered this issue in the "kickstarting" section on FreedomSponsors. This means that if you need this issue that bad, you can go to http://www.freedomsponsors.org/core/issue/113/jobs-trigger-continually-even-though-there-are-no-changes-due-to-git-repository-being-corrupt and offer a few bucks for it.

        jzaun Justin Zaun added a comment -

        Is it at least possible to not trigger the build on this error and just wait till the next check?

        ndeloof Nicolas De Loof added a comment -

        fixed by switching to JGit implementation in git-client plugin
        using git cli and parsing output is a fragile solution that I expect to fully replace with pure JGit

        seanf Sean Flanigan added a comment -

        It seems that JGit was later disabled by default in git-client-plugin 1.0.5 because of problems with JGit.

        Is there a solution for this continual trigger problem when using git cli?


          People

          • Assignee:
            Unassigned
            Reporter:
            james_cookie James Cook
          • Votes:
            15 Vote for this issue
            Watchers:
            20 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: