Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1163

Perforce plugin syncs to master instead of slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Date: Tue, 8 Jan 2008 13:02:48 -0800 (PST)
      From: Eli Sakamoto <elis@autonomy.com>
      Content-Type: text/plain; charset=us-ascii
      Subject: Perforce plugin syncs to master instead of slave

      Hi,

      I'm running a simple setup with a master running under Winstone and one
      slave. Both machines run Linux and have a user and group both named hudson.
      The master ssh's into the slave using public key authentication, and seems
      to work fine as far as I can tell. I've set up a free-style software project
      job named "test" that is tied to the slave and syncs from a dedicated
      perforce workspace. I have Let Hudson Manage Workspace View unchecked, One
      Time Force Sync checked, and the Depot Path set to "//...". The master's
      home directory and the slave's remote FS path are both set to
      /home/hudson/.hudson, which are two separate local directories, one on each
      machine.

      When I commence the build, the directory /home/hudson/.hudson/workspace/test
      is created on the slave. However, when the actual p4 forced sync starts,
      another directory /home/hudson/.hudson/workspace/test is created on the
      master and then sync starts populating this directory, leaving the slave
      directory empty. As such, when the sync finishes and the compiling starts,
      it looks into the empty slave directory and the build fails. Is this the
      expected behaviour for the perforce plugin? If not, does anyone know what
      would cause this behaviour and how to rectify it?

      Best regards,
      Eli Sakamoto

      View this message in context:
      http://www.nabble.com/Perforce-plugin-syncs-to-master-instead-of-slave-tp14698703p14698703.html
      Sent from the Hudson users mailing list archive at Nabble.com.

        Attachments

          Issue Links

            Activity

            digerata digerata added a comment -

            Eli,

            I am looking into this. I have not used Hudson in master/slave mode, so I'm not sure what the expected
            result will be. I do know that Perforce is running on the master and that is why the sync is happening
            there. I am not sure how the files are supposed to be pushed to the slave. Will keep you posted.

            -Mike

            digerata digerata added a comment -

            Just to confirm, this is certainly a problem with the Perforce plugin. It does not support the Hudson
            remote slave feature. Will keep you posted on the progress of implementing this.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : digerata
            Path:
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/HudsonP4Executor.java
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/HudsonP4ExecutorFactory.java
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/HudsonPipedOutputStream.java
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceMailResolver.java
            trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=9238
            Log:

            • Committing potential resolution for issue 1163, support for hudson slaves. Credit goes to Victor Szoltysek for the patch.
            digerata digerata added a comment -
                • Issue 1656 has been marked as a duplicate of this issue. ***
            digerata digerata added a comment -

            Assigning this to Victor for posterity. Victor, don't worry about updating this. I'll close it out in a few
            when I deploy the updated plugin.

            digerata digerata added a comment -

            Fixed in version 1.0.12 of the plugin. You can find it in the downloads section.

            lestin lestin added a comment -

            I've seen if you actually want to ask the slave to use the same client name as the master, you can, using the ${basename}.
            But is there a place where i can configure the default to be using ${basename} or i'll have to do it per job basis?

            Thanks.


              People

              • Assignee:
                vicsz vicsz
                Reporter:
                esakamot esakamot
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: