Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11645

git plugin is extremely slow creating a clone - takes 5-8 minutes in jenkins job

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      jenkins with git plugin - git repositories are on a red hat linux server the build slave is debian 6.
    • Similar Issues:

      Description

      15:42:54 Started by an SCM change
      15:42:54 Building remotely on bslave02
      15:42:54 Checkout:anroot / /data/JBuilds/main_int_ci/anroot - hudson.remoting.Channel@3d3a029e:bslave02
      15:42:54 Using strategy: Default 15:42:54 Last Built Revision: Revision afd2af69357bfc1da44266a8d0797906d92654a0 (remotes/origin/main_int)
      15:42:54 Checkout:anroot / /data/JBuilds/main_int_ci/anroot - hudson.remoting.LocalChannel@17414c60
      15:42:54 Wiping out workspace first.

      15:45:25 Cloning the remote Git repository
      15:45:25 Cloning repository origin

      15:45:45 Fetching upstream changes from git@thoroughbred:flt/root.git
      15:45:46 Commencing build of Revision 5c7a1b04226274c55f16e0a9c331d577540b3146 (remotes/origin/main_int)
      15:45:46 Checking out Revision 5c7a1b04226274c55f16e0a9c331d577540b3146 (remotes/origin/main_int)
      15:50:07 No emails were triggered.

      It only takes 57seconds to clone the same repo when I run the git clone command manually.

        Attachments

          Activity

          mcote marlene cote created issue -
          mcote marlene cote made changes -
          Field Original Value New Value
          Priority Major [ 3 ] Critical [ 2 ]
          markewaite Mark Waite added a comment -

          I don't think there is much hope of duplicating this issue 18 months after it was reported. I didn't see this problem even back when it was reported (as far as I can recall).

          The Git plugin has been through major revisions since the bug was first reported. It still uses the same basic mechanism for cloning as it did at the time this bug was reported, and it still has many hundreds of users on Debian machines.

          If the original submitter can still duplicate the bug, hopefully they can provide additional information on how to configure a system that will show the bug.

          markewaite Mark Waite made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Cannot Reproduce [ 5 ]
          markewaite Mark Waite made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 141888 ] JNJira + In-Review [ 205460 ]

            People

            • Assignee:
              abayer Andrew Bayer
              Reporter:
              mcote marlene cote
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: