Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11677

Perforce Plugin Parameter substitution onlyworks for lower case parameter names

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: perforce-plugin
    • Labels:
      None
    • Environment:
      RedHat Linux
    • Similar Issues:

      Description

      Hi,

      I was trying to use the Perforce Plugins parameter substitution in the label field and couldn't get it to work until I changed my parameter name to all lowercase (string parameter of a parameterized free style build). I would have expected it to work with uppercase letters too. If there is no time to fix this, at least the help should be updated to point out the limitation.

      Another thing I noticed is rather a feature request than a bug I think. Leaving the parameter empty to force a build from top of the tree doesn't work because it still tries to specify a parameter. You can see the attempt to sync to '//depot/...@' which fails. Adding some logic to sync to //depot/... instead when the parameter is empty would be helpful.

      Thanks,
      Sandra

        Attachments

          Activity

          rpetti Rob Petti added a comment -

          I just tested it, and mixed case works fine... It is, however, case sensitive. Can you confirm that this is what the problem actually is?

          I'll take a look at the 2nd point right now. It should be a simple enough fix.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Rob Petti
          Path:
          src/main/java/hudson/plugins/perforce/PerforceSCM.java
          http://jenkins-ci.org/commit/perforce-plugin/49901db95786c02b319778a1f822b7cb7104ad1c
          Log:
          JENKINS-11677 only use the label field if the parameters in it resolve to something non-empty

          dogfood dogfood added a comment -

          Integrated in plugins_perforce #155
          JENKINS-11677 only use the label field if the parameters in it resolve to something non-empty

          Rob Petti :
          Files :

          • src/main/java/hudson/plugins/perforce/PerforceSCM.java
          rpetti Rob Petti added a comment -

          Fixed second problem, but still can't reproduce the first one. Closing ticket.


            People

            • Assignee:
              rpetti Rob Petti
              Reporter:
              smadden Sandra Madden
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: