Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11860

user.dir system property from master (linux) being pulled across to slave (windows)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: fitnesse-plugin
    • Labels:
      None
    • Environment:
      MASTER: Linux (amd64)
      SLAVE: Windows XP (x86)
    • Similar Issues:

      Description

      When running a Fitnesse build on a Windows slave via a Linux master, the command to execute fitnesse is adding "/var/lib/tomcat6/" to the string.

      This "/var/lib/tomcat6/" string would be coming from the Linux master, but cannot figure out from where.

      How can I prevent this setting from being pulled across to the Windows slave?

      Console Output:

      C:\Jenkins\workspace\TEST-Fitnesse-AM>exit 0
      hudson.plugins.fitnesse.FitnesseBuilder:

      {fitnessePortLocal=8085, fitnesseTargetPage=FrontPage, fitnesseTargetIsSuite=true, fitnessePathToJar=Java/fitnesse.jar, fitnesseJavaOpts=, fitnesseHttpTimeout=60000, fitnesseJavaWorkingDirectory=Java, fitnessePathToRoot=FitNesseRoot, fitnesseStart=True, fitnessePathToXmlResultsOut=fitnesse-result.xml}

      Starting new Fitnesse instance...
      [Java] $ "/var/lib/tomcat6/C:/Program Files/Java/jdk1.7.0_01/bin/java" -jar /var/lib/tomcat6/C:\Jenkins\workspace\TEST-Fitnesse-AM/Java/fitnesse.jar -d /var/lib/tomcat6/C:\Jenkins\workspace\TEST-Fitnesse-AM -r FitNesseRoot -p 8085
      java.io.IOException: Cannot run program "/var/lib/tomcat6/C:/Program Files/Java/jdk1.7.0_01/bin/java" (in directory "\var\lib\tomcat6\C:\Jenkins\workspace\TEST-Fitnesse-AM\Java"): CreateProcess error=123, The filename, directory name, or volume label syntax is incorrect
      at java.lang.ProcessBuilder.start(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:244)
      at hudson.Proc$LocalProc.<init>(Proc.java:216)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:707)
      at hudson.Launcher$ProcStarter.start(Launcher.java:338)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:932)
      at hudson.Launcher$RemoteLaunchCallable.call(Launcher.java:899)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at hudson.remoting.Engine$1$1.run(Engine.java:60)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: CreateProcess error=123, The filename, directory name, or volume label syntax is incorrect
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 17 more
      Build step 'Execute fitnesse tests' marked build as failure
      Finished: FAILURE

        Attachments

          Activity

          ashokm Ashok Manji added a comment -

          This is not a problem for me anymore. Not using this anymore. Closing.

          evernat evernat added a comment -

          No response from the reporter, so resolving as incomplete.

          evernat evernat added a comment -

          Is it reproduced with recent Jenkins and plugins versions?

          ashokm Ashok Manji added a comment -

          Does anyone have any thoughts/solutions/workarounds on this?

          I've moved onto a new clean master server and this does the same thing.
          The master (linux) server's "user.dir" (/opt/apache-tomcat-6.0.32) system property is added as a prefix to the fitnesse command:

          [TEST-Fitnesse-AM] $ java -jar /opt/apache-tomcat-6.0.32/C:\Jenkins\workspace\TEST-Fitnesse-AM/Java\fitnesse.jar -d /opt/apache-tomcat-6.0.32/C:\Jenkins\workspace\TEST-Fitnesse-AM -r FitNesseRoot -p 8085

          There must be some way to prevent this property being carried over from the master to the slave machine run..


            People

            • Assignee:
              Unassigned
              Reporter:
              ashokm Ashok Manji
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: