Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11901

FATAL: de/regnis/q/sequence/line/QSequenceLineRAData with Subversion Plugin v1.36

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.441
      Subversion Plugin ver. 1.36 (FAIL)
    • Similar Issues:

      Description

      Upgrading Subversion Plugin from v1.35 to 1.36 causes the following error to occur dugin SVN checkout:

      FATAL: de/regnis/q/sequence/line/QSequenceLineRAData
      java.lang.NoClassDefFoundError: de/regnis/q/sequence/line/QSequenceLineRAData
      at org.tmatesoft.svn.core.internal.wc.DefaultSVNOptions.createMerger(DefaultSVNOptions.java:561)
      at org.tmatesoft.svn.core.internal.wc.admin.SVNAdminArea.mergeProperties(SVNAdminArea.java:470)
      at org.tmatesoft.svn.core.internal.wc.SVNUpdateEditor15.closeFile(SVNUpdateEditor15.java:1103)
      at org.tmatesoft.svn.core.internal.wc.SVNUpdateEditor15.closeFile(SVNUpdateEditor15.java:626)
      at org.tmatesoft.svn.core.internal.wc.SVNAmbientDepthFilterEditor.closeFile(SVNAmbientDepthFilterEditor.java:141)
      at org.tmatesoft.svn.core.internal.wc.SVNCancellableEditor.closeFile(SVNCancellableEditor.java:141)
      at org.tmatesoft.svn.core.internal.io.svn.SVNEditModeReader.processCommand(SVNEditModeReader.java:162)
      at org.tmatesoft.svn.core.internal.io.svn.SVNEditModeReader.driveEditor(SVNEditModeReader.java:232)
      at org.tmatesoft.svn.core.internal.io.svn.SVNRepositoryImpl.update(SVNRepositoryImpl.java:1493)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.update(SVNUpdateClient.java:564)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:401)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:135)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:136)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:787)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:768)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:752)
      at hudson.FilePath.act(FilePath.java:783)
      at hudson.FilePath.act(FilePath.java:765)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:742)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:684)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1195)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:568)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:457)
      at hudson.model.Run.run(Run.java:1404)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:238)
      Caused by: java.lang.ClassNotFoundException: de.regnis.q.sequence.line.QSequenceLineRAData
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
      ... 27 more

      Have reverted to the working version 1.35 as 1.36 does not work.

        Attachments

          Issue Links

            Activity

            ashokm Ashok Manji added a comment -

            v1.37 works as expected. Closing the ticket.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kutzi
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/f1e335c6af8a64f0ceb225e6bdbdec98ccd083a0
            Log:
            quick fix for JENKINS-11901

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kutzi
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/f1e335c6af8a64f0ceb225e6bdbdec98ccd083a0
            Log:
            quick fix for JENKINS-11901

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kohsuke
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/3f188fa04b240fbad2c9fed7316231fa2c3eb323
            Log:
            [FIXED JENKINS-11901]
            integrated svnkit 1.3.6.1-jenkins-2 that correctly has the sequence-library dependency.

            Compare: https://github.com/jenkinsci/subversion-plugin/compare/d13fd0c...3f188fa

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: kohsuke
            Path:
            pom.xml
            http://jenkins-ci.org/commit/subversion-plugin/3f188fa04b240fbad2c9fed7316231fa2c3eb323
            Log:
            [FIXED JENKINS-11901]
            integrated svnkit 1.3.6.1-jenkins-2 that correctly has the sequence-library dependency.

            Compare: https://github.com/jenkinsci/subversion-plugin/compare/d13fd0c...3f188fa


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                ashokm Ashok Manji
              • Votes:
                19 Vote for this issue
                Watchers:
                25 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: