Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-11937

Excluded regions only work for one check-in after a build

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: git-plugin
    • Labels:
    • Environment:
      Windows 7 64-bit, Git Plugin 1.1.13
    • Similar Issues:

      Description

      For our build environment, I am using the Git plugin (1.1.13) with Jenkins.

      In order to do incremental builds to cut down on total build time, I am using the excluded regions feature of the plugin. This feature appears to work, but only after one check-in.

      Here's my example:

      Check-in for project A.
      Project A builds.
      Check-in for project B.
      Project B builds (Project A correctly ignores the check-in for project B).
      Check-in for project B.
      Project A and B build (Project A does not ignore the check-in for project B when there are multiple check-ins to ignore).

      This issue appears to be similar to JENKINS-8342, however it does not appear to be dependent on the quiet period. This issue will happen 100% of the time in my environment when trying to ignore a 2nd check-in. I don't know after that point because the ignore list presumably gets reset after a build.

      This issue affects plugin version 1.1.12 and 1.1.13 in my testing.

        Attachments

          Issue Links

            Activity

            westhusing Adam Westhusing added a comment -

            Adding included regions would be a workaround for this issue, but in the current state this is a major issue for the plugin because it wastes time building projects that aren't necessary to build.

            westhusing Adam Westhusing added a comment -

            I think the issue with this was commits that are merges. The merges don't show up in Jenkins, but in the repository they contain changes that referred to projects not in the ignored list.

            Resolving as 'Cannot Reproduce'


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                westhusing Adam Westhusing
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: