Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12036

conditional step selections don't appear in "add build step" dropdown list in matrix (multi-config) projects

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      vmware ESXi 4
      debian 5.0 lenny
      jenkins 1.408 1.436 1.442
    • Similar Issues:

      Description

      To reproduce:
      =============
      install conditional step plugin ver 0.0.2
      create a new matrix project
      open project configuration page
      click "Add Build Step"
      Selections "conditional step" (single) and (mupltiple) are missing in the dropdown list

      Notes:
      ======

      • plugin works for simple free-style projects
      • previous version 0.0.1 works for matrix projects
      • some other plugins (for example "copy artifact") are also suppressed after "conditional-buildstep" ver 0.0.2 is installed

        Attachments

          Activity

          domi Dominik Bartholdi added a comment -

          because of some internal changes the plugin currently only supports freestyle and maven projects, but I'll look into this soon!

          which plugin exactly you'r not able to use in the conditional-buildstep anymore? because the "copy artifact" plugin works for me (https://wiki.jenkins-ci.org/display/JENKINS/Copy+Artifact+Plugin)

          yashma Adil Akhund-Zade added a comment -

          Thank you for your prompt response. My note above is a little vague and inaccurate. What I meant was:

          Some other plugins (e.g. "copy artifact") build steps also are missing in the dropdown list for_matrix_projects after "conditional-buildstep" ver 0.0.2 is installed

          domi Dominik Bartholdi added a comment -

          so you'r saying after installing the conditional-buildstep:0.2, you can't use the 'copy artifact' plugin in a matrix project anymore?
          hmm, that's even more strange - I really see way the conditional-buildstep could cause something like this.
          In the test I just made this works...
          ...is it the plugin I mentioned above?

          yashma Adil Akhund-Zade added a comment -

          I tried to reproduce the problem with blocking other plugins and could not. The experiment was not clean because since that time I deleted all plugins in my test installations and installed the latest from scratch. I stand corrected at "<blocking other build steps problem> - happened once"

          yashma Adil Akhund-Zade added a comment -

          I could reproduce the symptom in Notes (3) with Artifact deployer plugin.
          "Note 3 in the description: Artifact deployer is not available as a build step in matrix projects when conditional step plugin is also installed"

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: imod
          Path:
          src/main/java/org/jenkinsci/plugins/conditionalbuildstep/ConditionalBuilder.java
          src/main/java/org/jenkinsci/plugins/conditionalbuildstep/singlestep/SingleConditionalBuilder.java
          http://jenkins-ci.org/commit/conditional-buildstep-plugin/8ef5a4c965b77ce0bbe5595ce15f7c2eee750558
          Log:
          [FIXED JENKINS-12036] conditional steps don't appear in matrix (multi-config) projects


            People

            • Assignee:
              domi Dominik Bartholdi
              Reporter:
              yashma Adil Akhund-Zade
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: