Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12201

NullPointerException during SVN update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.443
      Subversion plugin 1.37
    • Similar Issues:

      Description

      Next run is working fine.

      org.tmatesoft.svn.core.SVNException: svn: REPORT /repos/bcp/!svn/vcc/default failed
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:298)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:283)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:271)
      at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.doReport(DAVConnection.java:283)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.runReport(DAVRepository.java:1282)
      at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.update(DAVRepository.java:830)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.update(SVNUpdateClient.java:564)
      at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:401)
      at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:135)
      at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:136)
      at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:787)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:768)
      at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:752)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2030)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: REPORT /repos/bcp/!svn/vcc/default failed
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
      ... 23 more
      Caused by: org.tmatesoft.svn.core.SVNException: svn: REPORT request failed on '/repos/bcp/!svn/vcc/default'
      svn: chunked stream ended unexpectedly
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
      at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:662)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:292)
      ... 22 more
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: REPORT request failed on '/repos/bcp/!svn/vcc/default'
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:660)
      ... 23 more
      Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: chunked stream ended unexpectedly
      at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:101)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:426)
      ... 23 more
      Caused by: java.io.IOException: chunked stream ended unexpectedly
      at org.tmatesoft.svn.core.internal.util.ChunkedInputStream.getChunkSizeFromInputStream(ChunkedInputStream.java:108)
      at org.tmatesoft.svn.core.internal.util.ChunkedInputStream.nextChunk(ChunkedInputStream.java:92)
      at org.tmatesoft.svn.core.internal.util.ChunkedInputStream.read(ChunkedInputStream.java:64)
      at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:264)
      at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:306)
      at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:158)
      at java.io.InputStreamReader.read(InputStreamReader.java:167)
      at org.tmatesoft.svn.core.internal.io.dav.http.XMLReader.read(XMLReader.java:39)
      at org.apache.xerces.impl.XMLEntityScanner.load(Unknown Source)
      at org.apache.xerces.impl.XMLEntityScanner.scanContent(Unknown Source)
      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanContent(Unknown Source)
      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
      at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
      at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
      at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.readData(HTTPConnection.java:776)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.readData(HTTPConnection.java:741)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPRequest.dispatch(HTTPRequest.java:218)
      at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:379)
      ... 23 more
      FATAL: null
      java.lang.NullPointerException
      at java.util.ArrayList.addAll(ArrayList.java:497)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:742)
      at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:684)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1195)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:568)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:457)
      at hudson.model.Run.run(Run.java:1404)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:238)

        Attachments

          Issue Links

            Activity

            akuhtz Andreas Kuhtz added a comment -

            I've a similar issue with 1'447 and Subversion plugin 1.37.
            The bad thing is that no mail is triggered if this error happens (I use Jenkins Email Extension Plugin 2.16).

            Updating https://svn*.****.******.net:8443/svn/*****/trunk/*******
            ERROR: Failed to update https://svn*.****.******.net:8443/svn/*****/trunk/*******
            org.tmatesoft.svn.core.SVNException: svn: OPTIONS /svn/*****/trunk/******* failed
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:298)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:283)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:271)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:533)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:98)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1011)
            	at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getRepositoryUUID(DAVRepository.java:148)
            	at org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:342)
            	at org.tmatesoft.svn.core.wc.SVNBasicClient.createRepository(SVNBasicClient.java:330)
            	at org.tmatesoft.svn.core.wc.SVNUpdateClient.update(SVNUpdateClient.java:535)
            	at org.tmatesoft.svn.core.wc.SVNUpdateClient.doUpdate(SVNUpdateClient.java:401)
            	at hudson.scm.subversion.UpdateUpdater$TaskImpl.perform(UpdateUpdater.java:135)
            	at hudson.scm.subversion.WorkspaceUpdater$UpdateTask.delegateTo(WorkspaceUpdater.java:136)
            	at hudson.scm.SubversionSCM$CheckOutTask.perform(SubversionSCM.java:787)
            	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:768)
            	at hudson.scm.SubversionSCM$CheckOutTask.invoke(SubversionSCM.java:752)
            	at hudson.FilePath.act(FilePath.java:784)
            	at hudson.FilePath.act(FilePath.java:766)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:742)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:684)
            	at hudson.model.AbstractProject.checkout(AbstractProject.java:1195)
            	at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:573)
            	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:462)
            	at hudson.model.Run.run(Run.java:1404)
            	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:481)
            	at hudson.model.ResourceController.execute(ResourceController.java:88)
            	at hudson.model.Executor.run(Executor.java:238)
            Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: OPTIONS /svn/*****/trunk/******* failed
            	at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
            	at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:146)
            	at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:89)
            	... 27 more
            Caused by: org.tmatesoft.svn.core.SVNException: svn: OPTIONS request failed on '/svn/*****/trunk/*******'
            svn: unknown host
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)
            	at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:662)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:292)
            	... 26 more
            Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: OPTIONS request failed on '/svn/*****/trunk/*******'
            	at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:660)
            	... 27 more
            Caused by: org.tmatesoft.svn.core.SVNErrorMessage: svn: unknown host
            	at org.tmatesoft.svn.core.SVNErrorMessage.create(SVNErrorMessage.java:200)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:415)
            	... 27 more
            Caused by: java.net.UnknownHostException: svn*.****.********.net
            	at java.net.InetAddress.getAllByName0(Unknown Source)
            	at java.net.InetAddress.getAllByName(Unknown Source)
            	at java.net.InetAddress.getAllByName(Unknown Source)
            	at java.net.InetAddress.getByName(Unknown Source)
            	at org.tmatesoft.svn.core.internal.util.SVNSocketFactory.createAddres(SVNSocketFactory.java:141)
            	at org.tmatesoft.svn.core.internal.util.SVNSocketFactory.createSSLSocket(SVNSocketFactory.java:72)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.connect(HTTPConnection.java:189)
            	at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection._request(HTTPConnection.java:354)
            	... 27 more
            FATAL: null
            java.lang.NullPointerException
            	at java.util.ArrayList.addAll(Unknown Source)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:742)
            	at hudson.scm.SubversionSCM.checkout(SubversionSCM.java:684)
            	at hudson.model.AbstractProject.checkout(AbstractProject.java:1195)
            	at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:573)
            	at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:462)
            	at hudson.model.Run.run(Run.java:1404)
            	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:481)
            	at hudson.model.ResourceController.execute(ResourceController.java:88)
            	at hudson.model.Executor.run(Executor.java:238)
            
            msolnit msolnit added a comment - - edited

            Same here. Using Jenkins build 1.447 and Subversion plugin 1.37. This also causes the Retry Count setting to be ignored (doesn't retry).

            dogfood dogfood added a comment -

            Integrated in plugins_subversion #143
            [FIXED JENKINS-12201] NullPointerException during SVN update (Revision 40267)

            Result = SUCCESS
            sogabe :
            Files :

            • /trunk/hudson/plugins/subversion/src/main/java/hudson/scm/subversion/UpdateUpdater.java
            sogabe sogabe added a comment -

            40267 | sogabe | 2012-01-29 16:45:59 +0900 (日, 29 1月 2012) | 2 lines

            [FIXED JENKINS-12201] NullPointerException during SVN update

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: sogabe
            Path:
            src/main/java/hudson/scm/subversion/UpdateUpdater.java
            http://jenkins-ci.org/commit/subversion-plugin/2459a51731b76a093b976204327f6f8cf5cddeab
            Log:
            [FIXED JENKINS-12201] NullPointerException during SVN update

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nicolas De Loof
            Path:
            src/main/java/hudson/scm/SubversionSCM.java
            src/main/java/hudson/scm/subversion/UpdateUpdater.java
            http://jenkins-ci.org/commit/subversion-plugin/09f17089fdbbfa202735bbd4fc4f0aa241045e64
            Log:
            [FIXED JENKINS-14629] return null to notify about checkout failure
            relates to JENKINS-12201


              People

              • Assignee:
                sogabe sogabe
                Reporter:
                cbos Cees Bos
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: