Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12267

Failure to load many builds when Jenkins start

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core, git-plugin
    • Labels:
      None
    • Environment:
      Debian Squeeze, amd64, Jenkins installed using the Debian package from pkg.jenkins-ci.org.
    • Similar Issues:

      Description

      When Jenkins is restarted, it fails to load most of the builds. The jenkins.log file contains many exceptions like this one:

      hudson.util.IOException2: Unable to read /var/lib/jenkins/jobs/bones/builds/2011-12-30_16-42-43/build.xml
              at hudson.XmlFile.unmarshal(XmlFile.java:160)
              at hudson.model.Run.reload(Run.java:283)
              at hudson.model.Run.<init>(Run.java:272)
              at hudson.model.AbstractBuild.<init>(AbstractBuild.java:162)
              at hudson.model.Build.<init>(Build.java:100)
              at hudson.model.FreeStyleBuild.<init>(FreeStyleBuild.java:41)
              at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
              at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
              at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
              at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
              at hudson.model.AbstractProject.loadBuild(AbstractProject.java:949)
              at hudson.model.AbstractProject$1.create(AbstractProject.java:256)
              at hudson.model.AbstractProject$1.create(AbstractProject.java:254)
              at hudson.model.RunMap.load(RunMap.java:221)
              at hudson.model.AbstractProject.onLoad(AbstractProject.java:254)
              at hudson.model.Project.onLoad(Project.java:88)
              at hudson.model.Items.load(Items.java:115)
              at jenkins.model.Jenkins$14.run(Jenkins.java:2360)
              at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
              at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
              at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
              at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
              at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:662)
      Caused by: com.thoughtworks.xstream.converters.ConversionException: Cannot deserialize object with new readObject()/writeObject() methods
      ---- Debugging information ----
      class               : hudson.model.FreeStyleBuild
      required-type       : org.eclipse.jgit.lib.ObjectId
      path                : /build/actions/hudson.plugins.git.util.BuildData/buildsByBranchName/entry/hudson.plugins.git.util.Build/revision/sha1
      line number         : 18
      -------------------------------
              at com.thoughtworks.xstream.converters.reflection.SerializableConverter.doUnmarshal(SerializableConverter.java:281)
              at com.thoughtworks.xstream.converters.reflection.AbstractReflectionConverter.unmarshal(AbstractReflectionConverter.java:162)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
              at com.thoughtworks.xstream.converters.collections.MapConverter.populateMap(MapConverter.java:79)
              at com.thoughtworks.xstream.converters.collections.MapConverter.unmarshal(MapConverter.java:66)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:71)
              at hudson.util.RobustCollectionConverter.populateCollection(RobustCollectionConverter.java:85)
              at com.thoughtworks.xstream.converters.collections.CollectionConverter.unmarshal(CollectionConverter.java:61)
              at hudson.util.RobustCollectionConverter.unmarshal(RobustCollectionConverter.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
              at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
              at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
              at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
              at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
              at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
              at hudson.util.XStream2.unmarshal(XStream2.java:91)
              at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
              at hudson.XmlFile.unmarshal(XmlFile.java:156)
              ... 25 more

      We're using Jenkins 1.445 but I think the problems is present for several versions; I can't tell when it started.

      The consequence is that many builds are missing in the UI. If the last build of a job is missing, a new build may be triggered (ie. for those depending on a VCS commit).

      A workaround is to click on "Reload Configuration from Disk" in the "Manage Jenkins" page. This properly reloads all builds and they are visible again.

        Attachments

          Issue Links

            Activity

            kutzi kutzi added a comment -

            According to the stacktrace this looks like it could be related to the git-plugin

            scottdugas Scott Dugas added a comment -

            I also ran into this issue today when I upgraded git from version 1.1.14 to 1.1.15

            m211 m211 added a comment -

            i have downgraded the git plugin to 1.1.14 .
            now my old builds are available.

            zaytsev Yury Zaytsev added a comment -

            Same problem here! Jenkins ver. 1.424.2 running on RHEL6 host from LTS native package, happened upon upgrade from git plugin 1.1.14 to 1.1.15. The workaround of reloading the configuration from disk helped.

            hudson.util.IOException2: Unable to read /var/lib/jenkins/jobs/fiji-full/builds/2011-12-23_12-17-08/build.xml
                    at hudson.XmlFile.unmarshal(XmlFile.java:157)
                    at hudson.model.Run.reload(Run.java:283)
                    at hudson.model.Run.<init>(Run.java:272)
                    at hudson.model.AbstractBuild.<init>(AbstractBuild.java:159)
                    at hudson.model.Build.<init>(Build.java:100)
                    at hudson.model.FreeStyleBuild.<init>(FreeStyleBuild.java:41)
                    at sun.reflect.GeneratedConstructorAccessor19.newInstance(Unknown Source)
                    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
                    at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
                    at hudson.model.AbstractProject.loadBuild(AbstractProject.java:947)
                    at hudson.model.AbstractProject$1.create(AbstractProject.java:256)
                    at hudson.model.AbstractProject$1.create(AbstractProject.java:254)
                    at hudson.model.RunMap.load(RunMap.java:221)
                    at hudson.model.AbstractProject.onLoad(AbstractProject.java:254)
                    at hudson.model.Project.onLoad(Project.java:88)
                    at hudson.model.Items.load(Items.java:115)
                    at jenkins.model.Jenkins$14.run(Jenkins.java:2273)
                    at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                    at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                    at jenkins.model.Jenkins$5.runTask(Jenkins.java:797)
                    at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                    at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
                    at java.lang.Thread.run(Thread.java:662)
            Caused by: com.thoughtworks.xstream.converters.ConversionException: Cannot deserialize object with new readObject()/writeObject() methods
            ---- Debugging information ----
            class               : hudson.model.FreeStyleBuild
            required-type       : org.eclipse.jgit.lib.ObjectId
            path                : /build/actions/hudson.plugins.git.util.BuildData/buildsByBranchName/entry/hudson.plugins.git.util.Build/revision/sha1
            line number         : 18
            -------------------------------
            
            ysw Yuriy Solodkyy added a comment -

            I have the same problem. Downgrade to 1.1.14 helps.

            gerd_zanker Gerd Zanker added a comment -

            I have the same problem with the git-plugin 1.1.16. Reloading the configuration from disk helps only in the current server session. If server is restarted many similar exceptions as in the description appear for nearly each done build. Downgraded to 1.1.14 to avoid problem.

            diedrich Lennart Diedrich added a comment -

            After downgrading to Git Plugin version 1.1.12 because of this problem I get the following Stacktrace with Jenkins 1.450:

            WARNING: Failed to resolve class
            com.thoughtworks.xstream.mapper.CannotResolveClassException: hudson.plugins.git.GitTagAction : hudson.plugins.git.GitTagAction
                    at com.thoughtworks.xstream.mapper.DefaultMapper.realClass(DefaultMapper.java:68)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.DynamicProxyMapper.realClass(DynamicProxyMapper.java:71)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.PackageAliasingMapper.realClass(PackageAliasingMapper.java:88)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.ClassAliasingMapper.realClass(ClassAliasingMapper.java:86)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.ArrayMapper.realClass(ArrayMapper.java:96)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at hudson.util.XStream2$CompatibilityMapper.realClass(XStream2.java:211)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at hudson.util.xstream.MapperDelegate.realClass(MapperDelegate.java:43)
                    at com.thoughtworks.xstream.mapper.MapperWrapper.realClass(MapperWrapper.java:38)
                    at com.thoughtworks.xstream.mapper.CachingMapper.realClass(CachingMapper.java:56)
                    at com.thoughtworks.xstream.core.util.HierarchicalStreams.readClassType(HierarchicalStreams.java:29)
                    at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.readItem(AbstractCollectionConverter.java:70)
                    at hudson.util.RobustCollectionConverter.populateCollection(RobustCollectionConverter.java:85)
                    at com.thoughtworks.xstream.converters.collections.CollectionConverter.unmarshal(CollectionConverter.java:61)
                    at hudson.util.RobustCollectionConverter.unmarshal(RobustCollectionConverter.java:76)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
                    at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
                    at hudson.util.RobustReflectionConverter.unmarshalField(RobustReflectionConverter.java:290)
                    at hudson.util.RobustReflectionConverter.doUnmarshal(RobustReflectionConverter.java:233)
                    at hudson.util.RobustReflectionConverter.unmarshal(RobustReflectionConverter.java:180)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convert(TreeUnmarshaller.java:82)
                    at com.thoughtworks.xstream.core.AbstractReferenceUnmarshaller.convert(AbstractReferenceUnmarshaller.java:63)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:76)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.convertAnother(TreeUnmarshaller.java:60)
                    at com.thoughtworks.xstream.core.TreeUnmarshaller.start(TreeUnmarshaller.java:137)
                    at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.unmarshal(AbstractTreeMarshallingStrategy.java:33)
                    at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:926)
                    at hudson.util.XStream2.unmarshal(XStream2.java:91)
                    at com.thoughtworks.xstream.XStream.unmarshal(XStream.java:912)
                    at hudson.XmlFile.unmarshal(XmlFile.java:156)
                    at hudson.model.Run.reload(Run.java:283)
                    at hudson.model.Run.<init>(Run.java:272)
                    at hudson.model.AbstractBuild.<init>(AbstractBuild.java:163)
                    at hudson.maven.AbstractMavenBuild.<init>(AbstractMavenBuild.java:54)
                    at hudson.maven.MavenModuleSetBuild.<init>(MavenModuleSetBuild.java:137)
                    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
                    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
                    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
                    at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
                    at hudson.model.AbstractProject.loadBuild(AbstractProject.java:949)
                    at hudson.model.AbstractProject$1.create(AbstractProject.java:256)
                    at hudson.model.AbstractProject$1.create(AbstractProject.java:254)
                    at hudson.model.RunMap.load(RunMap.java:221)
                    at hudson.model.AbstractProject.onLoad(AbstractProject.java:254)
                    at hudson.maven.MavenModuleSet.onLoad(MavenModuleSet.java:671)
                    at hudson.model.Items.load(Items.java:115)
                    at jenkins.model.Jenkins$14.run(Jenkins.java:2372)
                    at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:146)
                    at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
                    at jenkins.model.Jenkins$5.runTask(Jenkins.java:812)
                    at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
                    at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
                    at java.lang.Thread.run(Thread.java:636)
            
            albers Harald Albers added a comment - - edited

            Same setup with identical problem here. Reloading from disk solves the issue for the current session. Downgrading git plugin to 1.1.14 permanently resolves the issue.

            typek_pb Peter Butkovic added a comment -

            could someone provide steps for workaround? where is the 1.1.14 version available for download?

            dumbbell Jean-Sébastien Pédron added a comment -

            typek_pb: IIRC, you should have a "Downgrade to $VERSION" button in the "Installed plugins" tab in the Plugins management interface.

            albers Harald Albers added a comment -

            typek_pb: you can download it from http://updates.jenkins-ci.org/download/plugins/git/1.1.14/git.hpi and install it manually using jenkins' plugin upload feature.

            zaytsev Yury Zaytsev added a comment -

            I think this issue is a duplicate of JENKINS-12369 and has now been resolved.


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                dumbbell Jean-Sébastien Pédron
              • Votes:
                16 Vote for this issue
                Watchers:
                17 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: