Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12269

Latest build 1.445 breaks regression in Maven

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
    • Environment:
      1) agt-get on Ubuntu 11.10 with sun java and 32-bit
      2) java -jar on OSX 10.7.2

      Description

      The following exception occurs only after I upgraded to the latest build 1.445. I haven't got the time to debug the internal error. This error seems to happen after package lifecycle i.e. 'clean package' is ok but not 'clean verify'. I've also attached a maven project that I used which can reproduce this error.

      org.apache.maven.InternalErrorException: Internal error: java.lang.NullPointerException
      at org.apache.maven.lifecycle.internal.BuilderCommon.handleBuildError(BuilderCommon.java:128)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:95)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:319)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:79)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:158)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:112)
      at hudson.maven.Maven3Builder.call(Maven3Builder.java:70)
      at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      at hudson.remoting.Request$2.run(Request.java:287)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.NullPointerException
      at hudson.maven.ExecutedMojo.getMojoClass(ExecutedMojo.java:114)
      at hudson.maven.ExecutedMojo.<init>(ExecutedMojo.java:99)
      at hudson.maven.Maven3Builder$MavenExecutionListener.recordExecutionTime(Maven3Builder.java:524)
      at hudson.maven.Maven3Builder$MavenExecutionListener.recordMojoSucceeded(Maven3Builder.java:493)
      at hudson.maven.Maven3Builder$MavenExecutionListener.forkSucceeded(Maven3Builder.java:601)
      at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:97)
      at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
      at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:383)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      ... 24 more

        Issue Links

          Activity

          olamy olamy added a comment -

          dupe of JENKINS-12259

          olamy olamy added a comment -

          will be in 1.447


            People

            • Assignee:
              olamy olamy
              Reporter:
              stanlylau Stanly Lau
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: