Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12273

Double .app extension while compressing .dsym

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: xcode-plugin
    • Labels:
      None
    • Environment:
      Jenkins: 1.445
      XCode-Plugin: 1.2.2
    • Similar Issues:

      Description

      With version 1.2.2 packing up the .dsym file ended up in trying to pack Appname.app.app.dsym
      I create a pull request which fixes this issue for me.

        Attachments

          Activity

          aheritier Arnaud Héritier added a comment -

          ok, thx for your help. I'll merge it and I'll do some test tomorrow. I'll try to release the 1.2.3 with it. I have another issue to fix.

          aheritier Arnaud Héritier added a comment -

          You're right. I don't understand how this .app came here.
          Will be fixed in 1.2.3 release

          aheritier Arnaud Héritier added a comment -

          This 1.2.3-SNAPSHOT integrates your work

          ohoeltke Oliver H added a comment -

          packaging works, but hockeyapp.net does not like the included directory structure. Not sure about testflightapp.com.
          I will check this, hopefully in time for 1.2.3.
          Or is there any good reason to include the complete directory structure in the dsym zip?

          aheritier Arnaud Héritier added a comment -

          Myself it seems to work with appaloosa-store.com but we upload the .app and not the zip.
          No reason from my point of view but yes we have to take care to allow to use it with all possible services
          I didn't test testflightapp for a long time now. I need to think to have a test suite with it.
          I will wait a little bit for the 1.2.3, there is another bug I would like to investigate and it won't be before the end of the week.

          vxjasonxv Jason Salaz added a comment - - edited

          Any update on when you're going to deploy this? I'd love to start including the dSYMs in my TestFlight exports.

          aheritier Arnaud Héritier added a comment -

          Hi Jason,

          I may try to release 1.3 this week with what we have for now.
          Oliver told that the bug was fixed but that the generated DSYM zip didn't work for testFlight App.
          I didn't test this feature with this service thus I'm not sure you' ll be able to use it.
          What is happening if you test the attached plugin ? Is it working ?
          I can also give you a more recent build to validate the 1.3 release which is coming.

          Arnaud

          vxjasonxv Jason Salaz added a comment -

          I'm really sorry about not getting back to you sooner. But good news! I updated to 1.3 today and the dSYM zip is working, and the TestFlight upload seems to be happy with it too!

          Thanks.

          aheritier Arnaud Héritier added a comment -

          cool, good news ! Thx for your help

          ohoeltke Oliver H added a comment -

          Hey,
          I had some busy weeks, so I'm little late.
          As you already know, testflight works fine.
          hockeyapp.net doesn't work.
          If written a jenkins plugin for hockeyapp (wip: https://github.com/ohoeltke/hockeyapp-plugin).
          But I didn't get the dsym.zip right till now.
          The problem ist the full directory structure in the dsym.zip (starting at /).
          I will try to find a solution which will work with testflight and hockeyapp this weekend.

          aheritier Arnaud Héritier added a comment -

          Ok Oliver. Don't hesitate to open a new issue if we need to change how the .dsym is created


            People

            • Assignee:
              aheritier Arnaud Héritier
              Reporter:
              ohoeltke Oliver H
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: