Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12293

Incorrect inserting environment variables on linux slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: envinject-plugin
    • Labels:
      None
    • Environment:
      master-windows, slave-linux
    • Similar Issues:

      Description

      I have problem with new plugin 1.5/1.6 (1.2 works well) on slave (linux) node. I've tried this plugin using "Inject environment variables to the build process" in "build environments". I used cmakebuilder plugin (not significant). Although a building process fail with cmake errors It is probably error in EnvInject plugin 1.5 version because the building process in 1.2 is ok. Bookmarks "Injected Environment Variable" in 1.2 contains environment variables from linux (slave), but 1.5/1.6 contains environment variable from windows (master). Thanks!

        Attachments

          Activity

          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Gregory Boissinot
          Path:
          src/main/java/org/jenkinsci/plugins/envinject/EnvInjectComputerListener.java
          http://jenkins-ci.org/commit/envinject-plugin/948cf472a104f89f8ecccabcf71c40f585a01eed
          Log:
          Fix JENKINS-12293

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Gregory Boissinot Path: src/main/java/org/jenkinsci/plugins/envinject/EnvInjectComputerListener.java http://jenkins-ci.org/commit/envinject-plugin/948cf472a104f89f8ecccabcf71c40f585a01eed Log: Fix JENKINS-12293
          Hide
          gbois Gregory Boissinot added a comment -

          Thank you very much for all your inputs.
          Could you try the version 1.7. The problem should be fixed.

          Show
          gbois Gregory Boissinot added a comment - Thank you very much for all your inputs. Could you try the version 1.7. The problem should be fixed.
          Hide
          pezzu Peter Sukhenko added a comment -

          1.7 works fine for me.
          Thanks

          Show
          pezzu Peter Sukhenko added a comment - 1.7 works fine for me. Thanks
          Hide
          mwebber Matthew Webber added a comment -

          Also working ok for me (Linux master 32-bit, Linux slave 64-bit). Thanks.

          Show
          mwebber Matthew Webber added a comment - Also working ok for me (Linux master 32-bit, Linux slave 64-bit). Thanks.
          Hide
          ferda juraj fedorko added a comment -

          Yes, it works correctly. Thanks.

          Show
          ferda juraj fedorko added a comment - Yes, it works correctly. Thanks.

            People

            • Assignee:
              gbois Gregory Boissinot
              Reporter:
              ferda juraj fedorko
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: