Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12350

Characters missing or wrongly displayed in MSBuild Output in Jenkins

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: msbuild-plugin
    • Labels:
    • Environment:
      Tested on Win7 x64
      Jenkins ver. 1.447-SNAPSHOT (rc-01/05/2012 08:51 GMT-jenkins) (but also reproduced on last stable jenkins & last stable hudson 2.2)
      Jenkins MSBuild Plugin 1.8.2
    • Similar Issues:

      Description

      When displaying MSBuild output, accents and special caracters are not displayed properly:
      Here is a sample load.proj file :
      If you run it from CMD :

      C:\>C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe load.proj
      Microsoft (R) Build Engine, Version 4.0.30319.1
      [Microsoft .NET Framework, Version 4.0.30319.239]
      Copyright (C) Microsoft Corporation 2007. Tous droits réservés.

      La génération a démarré 10/01/2012 09:51:28.
      Projet "C:\load.proj" sur le noud 1
      (cibles par défaut).
      run:
      éà@u$ù
      Génération du projet "C:\load.proj"
      terminée (cibles par défaut).

      La génération a réussi.
      0 Avertissement(s)
      0 Erreur(s)

      Temps écoulé 00:00:00.04

      Both message comming from MSBuild and message comming from my .proj are displayed properly (with éè...)
      When executed from jenkins:

      Path To MSBuild.exe: C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe
      Executing command: cmd.exe /C C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe load.proj && exit %%ERRORLEVEL%%
      [dummy test] $ cmd.exe /C C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe load.proj && exit %%ERRORLEVEL%%
      Microsoft (R) Build Engine, Version 4.0.30319.1
      [Microsoft .NET Framework, Version 4.0.30319.239]
      Copyright (C) Microsoft Corporationÿ2007. Tous droits r‚serv‚s.

      La g‚n‚ration a d‚marr‚ 10/01/2012 09:55:11.
      Projet "C:\load.proj" sur le noud 1 (cibles par d‚faut).
      run:
      ‚...@u$—
      G‚n‚ration du projet "C:\load.proj" termin‚e (cibles par d‚faut).

      La g‚n‚ration a r‚ussi.
      0 Avertissement(s)
      0 Erreur(s)

      Temps ‚coul‚ 00:00:00.04
      Finished: SUCCESS

      You can see that "génération" is written "g‚n‚ration" with missing "é"

      [EDIT] It does not seems to be related to MSBuild plugin, but rather to MSBuild
      I tried a different approach and run MSBuild from a command line task inside jenkins:
      [dummy test] $ cmd /c call C:\Users\xxx\AppData\Local\Temp\hudson3226420618812873918.bat

      C:\>C:\Windows\Microsoft.NET\Framework\v4.0.30319\MSBuild.exe load.proj
      Microsoft (R) Build Engine, Version 4.0.30319.1
      [Microsoft .NET Framework, Version 4.0.30319.239]
      Copyright (C) Microsoft Corporationÿ2007. Tous droits r‚serv‚s.

      La g‚n‚ration a d‚marr‚ 10/01/2012 10:03:35.
      Projet "C:\load.proj" sur le noud 1 (cibles par d‚faut).
      run:
      ‚...@u$—
      G‚n‚ration du projet "C:\load.proj" termin‚e (cibles par d‚faut).

      La g‚n‚ration a r‚ussi.
      0 Avertissement(s)
      0 Erreur(s)

      Temps ‚coul‚ 00:00:00.04

      C:\>exit 0
      Finished: SUCCESS
      So it is not related to MSBuild plugin as suggested in the issue : https://issues.jenkins-ci.org/browse/JENKINS-10856
      But rather to MSBuild.
      I also tested a simple command :
      echo éè
      and it works without problem.

        Attachments

          Activity

          gbois Gregory Boissinot added a comment -

          Not a Jenkins Msbuild plugin issue


            People

            • Assignee:
              kdsweeney kdsweeney
              Reporter:
              tomap Thomas P
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: