Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12355

NPE on start page after deploying to WebSphere

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: ssh-slaves-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Error reported on start page with the following stack trace:

      org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:246)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:43)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:811)
      at jenkins.model.Jenkins.<init>(Jenkins.java:732)
      at hudson.model.Hudson.<init>(Hudson.java:81)
      at hudson.model.Hudson.<init>(Hudson.java:77)
      at hudson.WebAppMain$2.run(WebAppMain.java:217)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:124)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:800)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:897)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:919)
      at java.lang.Thread.run(Thread.java:736)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:60)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      at java.lang.reflect.Method.invoke(Method.java:611)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at org.jenkinsci.main.modules.sshd.SSHD.init(SSHD.java:133)
      ... 13 more

      Jenkins not usable.

      The bug may be related to https://issues.jenkins-ci.org/browse/JENKINS-12338 with a similar stack trace. However, Jenkins is started stand-alone in that issue. A common fact is that both use the IBM J9 JDK. Maybe a JDK incompatibility?

      Several other stacktraces in SystemOut.log of Websphere (see attachment).

        Attachments

          Issue Links

            Activity

            wattsc3 Chris Watts added a comment -

            I also got that error running inside Tomcat on solaris.

            Noticed this in the log:
            1) Error injecting constructor, java.lang.LinkageError: loader constraint violation: when resolving method "org.slf4j.impl.StaticLoggerBinder.getLoggerFactory()Lorg/slf4j/ILoggerFactory;" the class loader (i
            nstance of org/apache/catalina/loader/WebappClassLoader) of the current class, org/slf4j/LoggerFactory, and the class loader (instance of org/apache/catalina/loader/StandardClassLoader) for resolved class, o
            rg/slf4j/impl/StaticLoggerBinder, have different Class objects for the type org/slf4j/ILoggerFactory used in the signature
            at org.jenkinsci.main.modules.sshd.SSHD.<init>(SSHD.java:40)

            Discovered the problem was that I had slf4j-api.1.5.8.jar in tomcat/lib while jenkins is bundled with version 1.6.1 (upgrading or deleting it should fix it)

            coolmischa Mischa Soujon added a comment -

            Thanks Chris Watts to the hint on slf4.
            I have jenkins installed on a SLES Madchine with tomcat 6 installation:
            SUSE Linux Enterprise Server 11 (x86_64)
            VERSION = 11
            PATCHLEVEL = 1
            tomcat6-6.0.18-20.3.1

            This installation does not contain slf4j. I have manually added the following libs into the tomcat6/lib directory

            jcl-over-slf4j-1.6.4.jar
            log4j-over-slf4j-1.6.4.jar
            slf4j-api-1.6.4.jar

            and also updated the jenkins.1448.war with the slf4j-api*.jar to reflect the current version of slf4. After that everything is okay and I'm able to use JENKINS again

            Hope that helps and may be jenkins caontain the newer slf4j api it self.

            Regards

            Mischa

            hendyirawan Hendy Irawan added a comment -

            For me, upgrading from Jenkins 1.475 to Jenkins 1.495 solved the problem

            My environment:

            • Linux Mint 14 KDE (based on Ubuntu quantal 12.10), 64-bit

            ceefour@annafi:~$ uname -a
            Linux annafi.dev 3.5.0-21-generic #32-Ubuntu SMP Tue Dec 11 18:51:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
            ceefour@annafi:~$ java -version
            java version "1.7.0_09"
            OpenJDK Runtime Environment (IcedTea7 2.3.3) (7u9-2.3.3-0ubuntu1~12.10.1)
            OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

            kohsuke Kohsuke Kawaguchi added a comment -

            SSHD module 1.4 fixes this problem by making that failure non-fatal.
            This has been integrated into the core since 1.492 (commit:3a3f64494c97e824dcdbcdc3141bd1da1c746bae)


              People

              • Assignee:
                kohsuke Kohsuke Kawaguchi
                Reporter:
                ace130 Murx Brothers
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: