Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12427

BuildResultTrigger Plug-in not triggering job

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Linux, 2.6.26-amd64
      debian_version 5.0.6
      Jenkins BuildResultTrigger Plug-in 0.4
      Jenkins ver. 1.440
    • Similar Issues:
      Show 5 results

      Description

      Jenkins with the buildResultTrigger plugin is unable to trigger a job

      Two jobs are setup,
      1. TEST-TRIGGER is a basic job that always passes
      (from jenkins log)
      INFO | jvm 2 | 2012/01/17 10:47:31 | 17/01/2012 10:47:31 AM hudson.model.Run run
      INFO | jvm 2 | 2012/01/17 10:47:31 | INFO: TEST-Trigger #7 main build action completed: SUCCESS

      2. TEST-TRY is a basic job configured to Monitor build results of TEST-Trigger. This job is able to run with success when trigger manually
      (from jenkins log)
      INFO | jvm 2 | 2012/01/17 10:48:51 | 17/01/2012 10:48:51 AM hudson.model.Run run
      INFO | jvm 2 | 2012/01/17 10:48:51 | INFO: TEST-TRY #2 main build action completed: SUCCESS

      However, a success result from TEST-TRIGGER does not fire the TEST-TRY job.
      Both jobs configurations are attached

        Attachments

          Issue Links

            Activity

            sp S P created issue -
            sp S P made changes -
            Field Original Value New Value
            Component/s buildresulttrigger [ 15924 ]
            gbois Gregory Boissinot made changes -
            Assignee gbois [ gbois ]
            gbois Gregory Boissinot added a comment -

            According the config files, there are no build results to check. Therefore, you have to click on the button 'Add a build result' in the build-result section.

            Do not hesitate to reopen the issue if it doesn't fix the issue.

            gbois Gregory Boissinot made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Not A Defect [ 7 ]
            sp S P added a comment -

            updated to include more build results

            sp S P made changes -
            Attachment TEST-TRY.config-2.xml [ 21572 ]
            sp S P added a comment -

            OK, that is weird. The drop downs were selected when I opened the job. I've added more build results and they are visible in the config but still no firing of the job. I've added a updated config file. TEST-TRY.config-2.xml

            sp S P made changes -
            Resolution Not A Defect [ 7 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            gbois Gregory Boissinot added a comment -

            OK,
            Be careful for your cron expression

            '* * * * ' or '/1 * * * *' means each minute

            '1 * * * *' means each hour at 59

            Could you check your conf?

            sp S P added a comment -

            yep, thanks for the reminder, however the cron is fine in this case. I changed the job config 9 days ago, and triggered a fresh run of the watched job.

            gbois Gregory Boissinot added a comment -

            I'm afraid I can't reproduce your problem.
            It's OK in my environment.
            Could you try in your side to isolate the problem with a simple case/job and with a cron to 1 minute?

            gbois Gregory Boissinot added a comment -

            Any update?
            Thanks

            sp S P added a comment -

            Sorry for the delay.
            Yes I ran it again with a cron of 1 min, and no change.
            The jobs don't actually do anything, by that I mean they don't have any code they compile or tests they run, they are just empty jobs but they do finish with success. Do you think that could be the issue?
            Are you running the same job configs?
            We do have a bunch of other plugins in our jenkins. I wonder if something is interfering.

            gbois Gregory Boissinot added a comment -

            According your configuration files, you have to follow these rules:

            • You can't monitor the job itself
            • You have to add at least one result (SUCCESS, ....)

            And with these constraints, it's OK in my environment.

            gbois Gregory Boissinot added a comment -

            Does it suit you?

            sp S P added a comment -

            Yes, those rules you mention are fine for what I'm trying to do.
            I can't figure out why it isn't working for us and I don't know where else to look.
            I'll close the issue and try to work on it again another day.
            Thanks for your time

            sp S P made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Cannot Reproduce [ 5 ]
            bduffy Brent Duffy made changes -
            Link This issue is related to JENKINS-14446 [ JENKINS-14446 ]
            alghe Alexandru Gheorghe made changes -
            Link This issue is related to JENKINS-25753 [ JENKINS-25753 ]

              People

              • Assignee:
                gbois Gregory Boissinot
                Reporter:
                sp S P
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: