Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12449

Subversion java.lang.NoClassDefFoundError: org/tmatesoft/svn/core/auth/ISVNAuthenticationProvider

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      Hi, I just installed Jenkins on a new windows box. I'm having issues getting the subversion plugin to load. I'm trying to use 1.34 (tried updating to 1.37 and it didn't take). Any thoughts?
      The log is below... my system properties are below that:Jan 17, 2012 4:50:59 PM hudson.WebAppMain$2 run
      INFO: Jenkins is fully up and running
      Jan 17, 2012 4:50:48 PM hudson.TcpSlaveAgentListener <init>
      INFO: JNLP slave agent listener started on TCP port 54561
      Jan 17, 2012 4:50:48 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Completed initialization
      Jan 17, 2012 4:50:48 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Loaded all jobs
      Jan 17, 2012 4:50:46 PM hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule configure
      WARNING: Failed to load hudson.scm.listtagsparameter.ListSubversionTagsParameterDefinition$DescriptorImpl
      java.lang.NoClassDefFoundError: org/tmatesoft/svn/core/auth/ISVNAuthenticationProvider
      at java.lang.Class.getDeclaredMethods0(Native Method)
      at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
      at java.lang.Class.privateGetPublicMethods(Unknown Source)
      at java.lang.Class.getMethods(Unknown Source)
      at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:409)
      at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:430)
      at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:229)
      at com.google.inject.spi.Elements.getElements(Elements.java:103)
      at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:136)
      at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      at com.google.inject.Guice.createInjector(Guice.java:94)
      at com.google.inject.Guice.createInjector(Guice.java:71)
      at hudson.ExtensionFinder$AbstractGuiceFinder.<init>(ExtensionFinder.java:243)
      at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:186)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:561)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:536)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:282)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.model.listeners.SaveableListener.fireOnChange(SaveableListener.java:77)
      at hudson.model.UpdateCenter.save(UpdateCenter.java:435)
      at hudson.util.PersistedList.onModified(PersistedList.java:152)
      at hudson.util.PersistedList.replaceBy(PersistedList.java:79)
      at hudson.model.UpdateCenter.load(UpdateCenter.java:449)
      at hudson.model.UpdateCenter.init(UpdateCenter.java:1369)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:812)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: org.tmatesoft.svn.core.auth.ISVNAuthenticationProvider
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 52 more
      Jan 17, 2012 4:50:46 PM hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule configure
      WARNING: Failed to load hudson.scm.SubversionSCM$DescriptorImpl
      java.lang.NoClassDefFoundError: org/tmatesoft/svn/core/SVNException
      at java.lang.Class.getDeclaredMethods0(Native Method)
      at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
      at java.lang.Class.privateGetPublicMethods(Unknown Source)
      at java.lang.Class.getMethods(Unknown Source)
      at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.resolve(ExtensionFinder.java:409)
      at hudson.ExtensionFinder$AbstractGuiceFinder$SezpozModule.configure(ExtensionFinder.java:430)
      at com.google.inject.AbstractModule.configure(AbstractModule.java:62)
      at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:229)
      at com.google.inject.spi.Elements.getElements(Elements.java:103)
      at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:136)
      at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:104)
      at com.google.inject.Guice.createInjector(Guice.java:94)
      at com.google.inject.Guice.createInjector(Guice.java:71)
      at hudson.ExtensionFinder$AbstractGuiceFinder.<init>(ExtensionFinder.java:243)
      at hudson.ExtensionFinder$GuiceFinder.<init>(ExtensionFinder.java:186)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at net.java.sezpoz.IndexItem.instance(IndexItem.java:181)
      at hudson.ExtensionFinder$Sezpoz._find(ExtensionFinder.java:561)
      at hudson.ExtensionFinder$Sezpoz.find(ExtensionFinder.java:536)
      at hudson.ExtensionFinder._find(ExtensionFinder.java:147)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:289)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:282)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.model.listeners.SaveableListener.fireOnChange(SaveableListener.java:77)
      at hudson.model.UpdateCenter.save(UpdateCenter.java:435)
      at hudson.util.PersistedList.onModified(PersistedList.java:152)
      at hudson.util.PersistedList.replaceBy(PersistedList.java:79)
      at hudson.model.UpdateCenter.load(UpdateCenter.java:449)
      at hudson.model.UpdateCenter.init(UpdateCenter.java:1369)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:812)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: org.tmatesoft.svn.core.SVNException
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 52 more
      Jan 17, 2012 4:50:45 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Augmented all extensions
      Jan 17, 2012 4:50:45 PM hudson.ExtensionFinder$Sezpoz scout
      WARNING: Failed to scout hudson.scm.SubversionSCM$DescriptorImpl
      java.lang.NoClassDefFoundError: org/tmatesoft/svn/core/SVNException
      at java.lang.Class.forName0(Native Method)
      at java.lang.Class.forName(Unknown Source)
      at hudson.ExtensionFinder$Sezpoz.scout(ExtensionFinder.java:599)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:283)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.ClassicPluginStrategy.findComponents(ClassicPluginStrategy.java:282)
      at hudson.ExtensionList.load(ExtensionList.java:278)
      at hudson.ExtensionList.ensureLoaded(ExtensionList.java:231)
      at hudson.ExtensionList.iterator(ExtensionList.java:138)
      at hudson.model.listeners.SaveableListener.fireOnChange(SaveableListener.java:77)
      at hudson.model.UpdateCenter.save(UpdateCenter.java:435)
      at hudson.util.PersistedList.onModified(PersistedList.java:152)
      at hudson.util.PersistedList.replaceBy(PersistedList.java:79)
      at hudson.model.UpdateCenter.load(UpdateCenter.java:449)
      at hudson.model.UpdateCenter.init(UpdateCenter.java:1369)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.InitializerFinder.invoke(InitializerFinder.java:120)
      at hudson.init.InitializerFinder$TaskImpl.run(InitializerFinder.java:184)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:259)
      at jenkins.model.Jenkins$5.runTask(Jenkins.java:812)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:187)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:94)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.ClassNotFoundException: org.tmatesoft.svn.core.SVNException
      at java.net.URLClassLoader$1.run(Unknown Source)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      at java.lang.ClassLoader.loadClass(Unknown Source)
      ... 30 more
      Jan 17, 2012 4:50:45 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Started all plugins
      Jan 17, 2012 4:50:45 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Prepared all plugins
      Jan 17, 2012 4:50:45 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Listed all plugins
      Jan 17, 2012 4:50:45 PM hudson.PluginManager$1$3$1 isDuplicate
      INFO: Ignoring C:\Program Files (x86)\Jenkins\plugins\subversion.jpi because C:\Program Files (x86)\Jenkins\plugins\subversion.hpi is already loaded
      Jan 17, 2012 4:50:39 PM jenkins.InitReactorRunner$1 onAttained
      INFO: Started initialization

        Attachments

          Issue Links

            Activity

            adrian Adrian M added a comment -

            Same here, after upgrade to 1.448.
            After wasting hours, the workflow of Vite worked, despite that all svn urls are removed and have to be added again.

            rec Richard Eckart de Castilho added a comment -

            Just for the record: I did not disable the Subversion plugin at all. I just stopped Jenkins, deleted the .hpi and renamed the .jpi to .hpi. When Jenkins came back up, everything was quite back to normal. I did not have to add back any URLs.

            yozh Artem Karpenko added a comment -

            The workaround from JENKINS-12514 worked for me (no missed SVN URLs) - although you should not delete unreadable data (you can do it when visiting Jenkins' warning at "Manage Jenkins" page) - otherwise you'll have to restore SVN settings for projects anyway.

            alexlehm Alex Lehmann added a comment -

            fixed with JENKINS-13129

            kutzi kutzi added a comment -

            Assume this is fixed because of Alex Lehmann's last comment


              People

              • Assignee:
                Unassigned
                Reporter:
                digitalsingularity Robert Kangas
              • Votes:
                10 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: