Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12536

NullPointerException in QualityCenterResultArchiver

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: qc-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.424 running on Linux; QTP 10.0 and HP QC 9.2 running on a Windows Jenkins slave
    • Similar Issues:

      Description

      This error occurs if QualityCenter.getTestSetLogFiles() returns null. This can happen if the tests did not run due to some error (which was my fault (again, see JENKINS-12389)) on the jenkins slave.

      ERROR: Publisher com.michelin.cio.hudson.plugins.qc.QualityCenterResultArchiver aborted due to exception
      java.lang.NullPointerException
      at java.util.ArrayList.addAll(ArrayList.java:472)
      at com.michelin.cio.hudson.plugins.qc.QualityCenterResultArchiver.perform(QualityCenterResultArchiver.java:81)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:36)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:682)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:657)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:635)
      at hudson.model.Build$RunnerImpl.post2(Build.java:161)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:604)
      at hudson.model.Run.run(Run.java:1400)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:175)

        Attachments

          Activity

          rseguy Romain Seguy added a comment -

          Have you tested release 1.2.1?

          thies Thies Fengler added a comment -

          Yes, it happens with 1.2.1
          This is not a duplicate of JENKINS-12389.

          rseguy Romain Seguy added a comment -

          Fixed in the upcoming 1.2.2.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: rseguy
          Path:
          src/main/java/com/michelin/cio/hudson/plugins/qc/QualityCenterResultArchiver.java
          http://jenkins-ci.org/commit/qc-plugin/3a2370e3455c40398af5bde997cd633f676e49b6
          Log:
          JENKINS-12536 NullPointerException in QualityCenterResultArchiver


            People

            • Assignee:
              rseguy Romain Seguy
              Reporter:
              thies Thies Fengler
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: