Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12544

mercurial generates illegal directory name on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: mercurial-plugin
    • Labels:
    • Environment:
      Windows 2003 R2
      Java 6.0.30
      Jenkins 1.242.2 LTS
      Mercurial plugin 1.38
    • Similar Issues:

      Description

      My local mercurial server runs on port 8000 and the plugin tries to use ":8000" in the filename. But : is an illegal character in a filename on Windows.

      Started by user anonymous
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" showconfig paths.default
      $ "C:\Program Files\Mercurial\hg.exe" clone --noupdate http://ronaldradial:8000/ C:\java\hudson\hgcache\DA7E6A4632009859A61A551999EE2109EBB69267-ronaldradial:8000
      abort: The directory name is invalid: C:\java\hudson\hgcache\DA7E6A4632009859A61A551999EE2109EBB69267-ronaldradial:8000
      ERROR: Failed to clone http://ronaldradial:8000/
      ERROR: Failed to use repository cache for http://ronaldradial:8000/
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" pull --rev default
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" update --clean --rev default
      2 files updated, 0 files merged, 0 files removed, 0 files unresolved
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" --config extensions.purge= clean --all
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" log --rev . --template

      {node}
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" log --rev bdd41ba264aa37472c5bf4be6bcb9e46be3c7633
      [workspace] $ "C:\Program Files\Mercurial\hg.exe" log --template "<changeset node='{node}

      ' author='

      {author|xmlescape}

      ' rev='

      {rev}

      ' date='

      {date}

      '><msg>

      {desc|xmlescape}

      </msg><added>

      {file_adds|stringify|xmlescape}

      </added><deleted>

      {file_dels|stringify|xmlescape}

      </deleted><files>

      {files|stringify|xmlescape}

      </files><parents>

      {parents}

      </parents></changeset>\n" --rev default:0 --follow --prune bdd41ba264aa37472c5bf4be6bcb9e46be3c7633
      [workspace] $ cmd /c call C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\hudson3374063823382421936.bat

        Attachments

          Activity

          javakoe Ronald Klop added a comment -

          Confirmed that it works for me.

          dogfood dogfood added a comment -

          Integrated in plugins_mercurial #99
          [FIXED JENKINS-12544] Illegal directory name on Windows when port number used in URL. (Revision fd76cf11527760b2f880ee81ee76a23d1b083079)

          Result = SUCCESS
          Jesse Glick :
          Files :

          • src/main/java/hudson/plugins/mercurial/Cache.java
          • src/test/java/hudson/plugins/mercurial/CacheTest.java
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          src/main/java/hudson/plugins/mercurial/Cache.java
          src/test/java/hudson/plugins/mercurial/CacheTest.java
          http://jenkins-ci.org/commit/mercurial-plugin/fd76cf11527760b2f880ee81ee76a23d1b083079
          Log:
          [FIXED JENKINS-12544] Illegal directory name on Windows when port number used in URL.

          Compare: https://github.com/jenkinsci/mercurial-plugin/compare/8d62fa2...fd76cf1


            People

            • Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              javakoe Ronald Klop
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: