Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-12750

Scriptler 2.0 breaks cc.xml-View for Anonymous User having READ perm on "Overall" and "Job"

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: scriptler-plugin
    • Labels:
    • Environment:
    • Similar Issues:

      Description

      After upgrading Jenkins to Scriptler 2.0 on Jenkins 1.450 calling "cc.xml" throws an 500 error:

      https://gist.github.com/1817603

      The error appears when calling the URL as an anonymous user having READ permissions on "Overall" and "Job".

      So I think it is somehow related with https://github.com/jenkinsci/scriptler-plugin/pull/2

      Downgrading to Scriptler 1.5 fixed the problem.

        Attachments

          Activity

          ctrabold Christian Trabold created issue -
          ctrabold Christian Trabold added a comment -

          Update: Downgrading fixed the Error-Message but made Scriptler disappear. :-/

          Could somebody confirm that it's not possible to install an older version of scriptler after installing 2.0?

          domi Dominik Bartholdi added a comment -

          unfortunately downgrade will most likely not work - the internal structure was changed quite a bit and therefore the format of the scriptler.xml changed too. ...Only upgrade is supported - sorry.

          Can you please explane what "cc.xml" is? Where does it come from? How can I reproduce the issue?

          ctrabold Christian Trabold added a comment -

          Reproduce by calling your http://jenkins-server:port/cc.xml

          The "cc.xml" is available on every Jenkins installation IIRC:

          https://wiki.jenkins-ci.org/display/JENKINS/Monitoring+Jenkins

          We use this file for monitoring all our build status. Thus most Build-Monitors could be affected by this issue I'm afraid.

          Too bad the downgrade doesn't work. My daily work pretty much depends on Scriptler (nice Plugin!)

          HTH

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: imod
          Path:
          src/main/java/org/jenkinsci/plugins/scriptler/ScriptlerManagment.java
          http://jenkins-ci.org/commit/scriptler-plugin/6a70d7f8913b6d01d3026a5959010e7449b10be9
          Log:
          a try to fix an issue with accessing cc.xml (JENKINS-12750)

          domi Dominik Bartholdi added a comment -

          as I can't reproduce it, its quite hard to find this issue - in fact I'm not sure how scriptler can cause anything like this.
          But I did make a small change with a little chance to fix it. Could you please have a try with this version:

          http://ci.jenkins-ci.org/view/Plugins/job/plugins_scriptler/lastBuild/org.jenkins-ci.plugins$scriptler/artifact/org.jenkins-ci.plugins/scriptler/2.1-SNAPSHOT/scriptler-2.1-SNAPSHOT.hpi

          let me know how it does...

          ctrabold Christian Trabold added a comment -

          Seems your change fixed the issue!

          1. I have "2.1-SNAPSHOT (private-02/17/2012 20:02-jenkins)" installed
          2. I can use Scriptler
          3. AND the cc.xml shows up with valid content!

          This is great news!

          BIG THANKS!

          domi Dominik Bartholdi added a comment -

          I'm glad it works, but I'm also confused - because I have no real explanation why this should change the behavior when accessing cc.xml
          I'll keep this change in, but I definitely have to dig deeper into this...

          domi Dominik Bartholdi added a comment -

          fixed with 2.1

          domi Dominik Bartholdi made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 143207 ] JNJira + In-Review [ 190441 ]
          danielbeck Daniel Beck made changes -
          Labels plugin cc.xml

            People

            • Assignee:
              domi Dominik Bartholdi
              Reporter:
              ctrabold Christian Trabold
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: