Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1285

Email notification don't take into account that Cobertura has set a build to unstable

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cobertura-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Cobertura is configured with an unstable threshold. The build is successful but
      the plugin sets this build to unstable. In this case, we don't receive a mail
      saying the build is unstable.
      At the next build, if this one is still successful but unstable, we receive a
      mail telling "the build is back to stable"… but it is not true. In fact the
      email is sending before the build is setting to unstable.

      Maven2 project configure as free-style project on Hudson 1.183 with Cobertura 0.8.4.

      (Same issue was noticed with the Clover plugin (1.6) and Hudson 1.183.)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed. Publishers who change the build status should be registered as a
          recorder, like:

          BuildStep.PUBLISHERS.addRecorder(CoberturaPublisher.DESCRIPTOR);

          remke remke added a comment -

          The comment by Kohsuke states the issue is fixed. However, I still experience
          this issue in version 0.8.8 of the Cobertura plugin with Hudson 1.313. Does this
          mean that the issue is fixed in the Hudson plugin API, but that it still needs
          to be applied to the Cobertura plugin? Can someone please clarify on this?


            People

            • Assignee:
              stephenconnolly Stephen Connolly
              Reporter:
              tcarre tcarre
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: